summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-04-05 16:19:52 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-04-05 16:19:52 +0000
commitdb7a7f3baebcd2104ed0bd2afb27a0ea6c7d1307 (patch)
tree172a58e16aa5c756b072522bd84caa5bebe43806 /sys-auth/pam_abl
parentUpdate deps again for bug #259667 (diff)
downloadgentoo-2-db7a7f3baebcd2104ed0bd2afb27a0ea6c7d1307.tar.gz
gentoo-2-db7a7f3baebcd2104ed0bd2afb27a0ea6c7d1307.tar.bz2
gentoo-2-db7a7f3baebcd2104ed0bd2afb27a0ea6c7d1307.zip
Add patch for as-needed, bug #248403
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_abl')
-rw-r--r--sys-auth/pam_abl/ChangeLog8
-rw-r--r--sys-auth/pam_abl/files/pam_abl-0.2.3-as-needed.patch11
-rw-r--r--sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild12
3 files changed, 24 insertions, 7 deletions
diff --git a/sys-auth/pam_abl/ChangeLog b/sys-auth/pam_abl/ChangeLog
index 3f351033294b..cf92b0bce04a 100644
--- a/sys-auth/pam_abl/ChangeLog
+++ b/sys-auth/pam_abl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/pam_abl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_abl/ChangeLog,v 1.7 2007/11/21 16:28:40 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_abl/ChangeLog,v 1.8 2009/04/05 16:19:52 jokey Exp $
+
+ 05 Apr 2009; Markus Ullmann <jokey@gentoo.org>
+ +files/pam_abl-0.2.3-as-needed.patch, pam_abl-0.2.3-r1.ebuild:
+ Add patch for as-needed, bug #248403
21 Nov 2007; Samuli Suominen <drac@gentoo.org> pam_abl-0.2.3-r1.ebuild:
amd64 stable wrt #197429
diff --git a/sys-auth/pam_abl/files/pam_abl-0.2.3-as-needed.patch b/sys-auth/pam_abl/files/pam_abl-0.2.3-as-needed.patch
new file mode 100644
index 000000000000..f18ecf68f9a6
--- /dev/null
+++ b/sys-auth/pam_abl/files/pam_abl-0.2.3-as-needed.patch
@@ -0,0 +1,11 @@
+--- tools/Makefile.orig 2008-12-28 17:27:47.000000000 +0100
++++ tools/Makefile 2008-12-28 17:31:08.000000000 +0100
+@@ -9,7 +9,7 @@
+ all : $(TARGET)
+
+ $(TARGET) : $(OBJ)
+- cc $(LIBS) -o $@ $^
++ cc -o $@ $^ $(LIBS)
+
+ install : $(TARGET)
+ install --mode=755 --strip $(TARGET) $(INSTDIR)
diff --git a/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild b/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild
index 6551ef3d8651..c5d81771a6fd 100644
--- a/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild
+++ b/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild,v 1.5 2007/11/21 16:28:40 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_abl/pam_abl-0.2.3-r1.ebuild,v 1.6 2009/04/05 16:19:52 jokey Exp $
+
+EAPI=2
inherit flag-o-matic pam toolchain-funcs
@@ -23,9 +25,9 @@ S=${WORKDIR}/${PN}
# restrict tests as they're broken badly
RESTRICT="test"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ # fix as-needed per bug # 248403
+ epatch "${FILESDIR}/${P}-as-needed.patch"
# fix hardcoded values in Makefile
sed -i -e "s:-Wall -fPIC:${CFLAGS} -Wall:" \