summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-11 13:53:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-11 13:53:10 +0000
commitf230965e2f19b09091f839abfe088527a56cbaff (patch)
tree2f20f282103e441103a7c0a1f16e6f6860a5a252 /sys-auth/pam-pgsql
parentpackage.masked the following packages: (diff)
downloadgentoo-2-f230965e2f19b09091f839abfe088527a56cbaff.tar.gz
gentoo-2-f230965e2f19b09091f839abfe088527a56cbaff.tar.bz2
gentoo-2-f230965e2f19b09091f839abfe088527a56cbaff.zip
Initial import of pam-pgsql, using a snapshot of the current development series from upstream, with a working autotools-based buildsystem. Closes bug #34517.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam-pgsql')
-rw-r--r--sys-auth/pam-pgsql/ChangeLog12
-rw-r--r--sys-auth/pam-pgsql/metadata.xml8
-rw-r--r--sys-auth/pam-pgsql/pam-pgsql-0.7_p20100311.ebuild45
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-auth/pam-pgsql/ChangeLog b/sys-auth/pam-pgsql/ChangeLog
new file mode 100644
index 000000000000..0c2b525829b5
--- /dev/null
+++ b/sys-auth/pam-pgsql/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sys-auth/pam-pgsql
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-pgsql/ChangeLog,v 1.1 2010/03/11 13:53:10 flameeyes Exp $
+
+*pam-pgsql-0.7_p20100311 (11 Mar 2010)
+
+ 11 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pam-pgsql-0.7_p20100311.ebuild, +metadata.xml:
+ Initial import of pam-pgsql, using a snapshot of the current development
+ series from upstream, with a working autotools-based buildsystem. Closes
+ bug #34517.
+
diff --git a/sys-auth/pam-pgsql/metadata.xml b/sys-auth/pam-pgsql/metadata.xml
new file mode 100644
index 000000000000..b3bf86cd59b4
--- /dev/null
+++ b/sys-auth/pam-pgsql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+<maintainer>
+<email>pam-bugs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/pam-pgsql/pam-pgsql-0.7_p20100311.ebuild b/sys-auth/pam-pgsql/pam-pgsql-0.7_p20100311.ebuild
new file mode 100644
index 000000000000..1143ff09ae97
--- /dev/null
+++ b/sys-auth/pam-pgsql/pam-pgsql-0.7_p20100311.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-pgsql/pam-pgsql-0.7_p20100311.ebuild,v 1.1 2010/03/11 13:53:10 flameeyes Exp $
+
+inherit eutils pam
+
+DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
+HOMEPAGE="http://sourceforge.net/projects/pam-pgsql/"
+
+if [[ ${PV} = *_p* ]]; then
+ SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/${P}.tar.gz"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+fi
+
+DEPEND="virtual/pam
+ >=dev-db/postgresql-base-8.0"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/security \
+ --libdir=/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake pammoddir="$(getpam_mod_dir)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pammoddir="$(getpam_mod_dir)" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ elog "Please see the documentation and configuration examples in the"
+ elog "documentation directory at /usr/share/doc/${PF}."
+ elog ""
+ elog "Please note that the default configuration file in Gentoo has been"
+ elog "moved to /etc/security/pam-pgsql.conf to follow the other PAM modules."
+}