summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-10-17 06:19:38 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-10-17 06:19:38 +0000
commitaba7653693c40ad21928d397fdfee140d5337481 (patch)
tree5f754824a2e21ae96df73d1775eceaf90bb7399f /sys-auth/pam-csync
parentRestricting python 2.5 (diff)
downloadgentoo-2-aba7653693c40ad21928d397fdfee140d5337481.tar.gz
gentoo-2-aba7653693c40ad21928d397fdfee140d5337481.tar.bz2
gentoo-2-aba7653693c40ad21928d397fdfee140d5337481.zip
Add patch to fix upstream rename of csync -> ocsync. Fixes bug #438510.
(Portage version: 2.1.11.28/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'sys-auth/pam-csync')
-rw-r--r--sys-auth/pam-csync/ChangeLog9
-rw-r--r--sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch33
-rw-r--r--sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild29
-rw-r--r--sys-auth/pam-csync/pam-csync-0.42.0.ebuild4
4 files changed, 72 insertions, 3 deletions
diff --git a/sys-auth/pam-csync/ChangeLog b/sys-auth/pam-csync/ChangeLog
index fb44c27b0d41..0d5ed0082361 100644
--- a/sys-auth/pam-csync/ChangeLog
+++ b/sys-auth/pam-csync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam-csync
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-csync/ChangeLog,v 1.2 2012/08/28 13:22:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-csync/ChangeLog,v 1.3 2012/10/17 06:19:38 kensington Exp $
+
+*pam-csync-0.42.0-r1 (17 Oct 2012)
+
+ 17 Oct 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/pam-csync-0.42.0-ocsync.patch, +pam-csync-0.42.0-r1.ebuild,
+ pam-csync-0.42.0.ebuild:
+ Add patch to fix upstream rename of csync -> ocsync. Fixes bug #438510.
28 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> pam-csync-0.42.0.ebuild:
Raise the dep over iniparser to be same as on csync.
diff --git a/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch b/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch
new file mode 100644
index 000000000000..117a2b0db26f
--- /dev/null
+++ b/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch
@@ -0,0 +1,33 @@
+Since 0.60.0, upstream renamed to "ocsync".
+
+--- cmake/Modules/FindCSYNC.cmake
++++ cmake/Modules/FindCSYNC.cmake
+@@ -20,7 +20,7 @@
+ else (CSYNC_LIBRARIES AND CSYNC_INCLUDE_DIRS)
+ find_path(CSYNC_INCLUDE_DIR
+ NAMES
+- csync/csync.h
++ ocsync/csync.h
+ PATHS
+ /usr/include
+ /usr/local/include
+@@ -30,7 +30,7 @@
+
+ find_library(CSYNC_LIBRARY
+ NAMES
+- csync
++ ocsync
+ PATHS
+ /usr/lib
+ /usr/local/lib
+--- src/pam_csync.c
++++ src/pam_csync.c
+@@ -50,7 +50,7 @@
+ #include <security/pam_modutil.h>
+ #include <security/pam_ext.h>
+
+-#include <csync/csync.h>
++#include <ocsync/csync.h>
+
+ #include "pam_csync.h"
+ #include "config.h"
diff --git a/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild b/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild
new file mode 100644
index 000000000000..c7bd72a042cf
--- /dev/null
+++ b/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild,v 1.1 2012/10/17 06:19:37 kensington Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="PAM module to provide roaming home directories for a user session"
+HOMEPAGE="http://www.csync.org/"
+SRC_URI="http://www.csync.org/files/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/iniparser-3.1
+ >=net-misc/csync-0.60.0
+ virtual/pam
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+"
+
+S="${WORKDIR}/${P/-/_}"
+
+PATCHES=( "${FILESDIR}/${P}-ocsync.patch" )
diff --git a/sys-auth/pam-csync/pam-csync-0.42.0.ebuild b/sys-auth/pam-csync/pam-csync-0.42.0.ebuild
index 6adeac515fe9..1285125c3a0a 100644
--- a/sys-auth/pam-csync/pam-csync-0.42.0.ebuild
+++ b/sys-auth/pam-csync/pam-csync-0.42.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-csync/pam-csync-0.42.0.ebuild,v 1.2 2012/08/28 13:22:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-csync/pam-csync-0.42.0.ebuild,v 1.3 2012/10/17 06:19:37 kensington Exp $
EAPI=4
@@ -17,7 +17,7 @@ IUSE=""
RDEPEND="
>=dev-libs/iniparser-3.1
- net-misc/csync
+ <net-misc/csync-0.60.0
virtual/pam
"
DEPEND="${DEPEND}