summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-29 00:47:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-29 00:47:00 +0000
commitacc589048a7191867416925dc180643149a2ae4f (patch)
tree2ec081a1719c03b5ecd3b947a65dfd0e3b3b450b /sys-auth/openpam
parentdev-libs/libsigc++: Bump to 2.2.2 (diff)
downloadgentoo-2-acc589048a7191867416925dc180643149a2ae4f.tar.gz
gentoo-2-acc589048a7191867416925dc180643149a2ae4f.tar.bz2
gentoo-2-acc589048a7191867416925dc180643149a2ae4f.zip
Bump to latest release, one chunk of our gentoo patch is not needed.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-auth/openpam')
-rw-r--r--sys-auth/openpam/ChangeLog8
-rw-r--r--sys-auth/openpam/files/openpam-20071221-gentoo.patch150
-rw-r--r--sys-auth/openpam/openpam-20071221.ebuild52
3 files changed, 209 insertions, 1 deletions
diff --git a/sys-auth/openpam/ChangeLog b/sys-auth/openpam/ChangeLog
index d0f146c344c3..373f7b9f77f7 100644
--- a/sys-auth/openpam/ChangeLog
+++ b/sys-auth/openpam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/openpam
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.9 2008/02/19 12:03:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.10 2008/03/29 00:46:59 flameeyes Exp $
+
+*openpam-20071221 (29 Mar 2008)
+
+ 29 Mar 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/openpam-20071221-gentoo.patch, +openpam-20071221.ebuild:
+ Bump to latest release, one chunk of our gentoo patch is not needed.
*openpam-20050616-r2 (19 Feb 2008)
diff --git a/sys-auth/openpam/files/openpam-20071221-gentoo.patch b/sys-auth/openpam/files/openpam-20071221-gentoo.patch
new file mode 100644
index 000000000000..4c0e152939b8
--- /dev/null
+++ b/sys-auth/openpam/files/openpam-20071221-gentoo.patch
@@ -0,0 +1,150 @@
+diff -Nur openpam-20050201/include/security/Makefile.am openpam-20050201-gentoo/include/security/Makefile.am
+--- openpam-20050201/include/security/Makefile.am 2005-02-01 00:00:00.000000000 +0100
++++ openpam-20050201-gentoo/include/security/Makefile.am 2005-06-11 12:48:19.038207056 +0200
+@@ -6,4 +6,5 @@
+ pam_appl.h \
+ pam_constants.h \
+ pam_modules.h \
+- pam_types.h
++ pam_types.h \
++ pam_mod_misc.h
+diff -Nur openpam-20050201/include/security/pam_mod_misc.h openpam-20050201-gentoo/include/security/pam_mod_misc.h
+--- openpam-20050201/include/security/pam_mod_misc.h 1970-01-01 01:00:00.000000000 +0100
++++ openpam-20050201-gentoo/include/security/pam_mod_misc.h 2005-06-11 12:48:19.038207056 +0200
+@@ -0,0 +1,56 @@
++/*-
++ * Copyright 1998 Juniper Networks, Inc.
++ * All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ *
++ * $FreeBSD: src/lib/libpam/libpam/security/pam_mod_misc.h,v 1.12 2003/05/31 16:56:35 des Exp $
++ */
++
++#ifndef PAM_MOD_MISC_H
++#define PAM_MOD_MISC_H
++
++#include <sys/cdefs.h>
++
++/*
++ * Common option names
++ */
++#define PAM_OPT_NULLOK "nullok"
++#define PAM_OPT_AUTH_AS_SELF "auth_as_self"
++#define PAM_OPT_ECHO_PASS "echo_pass"
++#define PAM_OPT_DEBUG "debug"
++
++__BEGIN_DECLS
++void _pam_verbose_error(pam_handle_t *, int, const char *,
++ const char *, const char *, ...);
++__END_DECLS
++
++#define PAM_LOG(...) \
++ openpam_log(PAM_LOG_DEBUG, __VA_ARGS__)
++
++#define PAM_RETURN(arg) \
++ return (arg)
++
++#define PAM_VERBOSE_ERROR(...) \
++ _pam_verbose_error(pamh, flags, __FILE__, __FUNCTION__, __VA_ARGS__)
++
++#endif
+diff -Nur openpam-20050201/lib/Makefile.am openpam-20050201-gentoo/lib/Makefile.am
+--- openpam-20050201/lib/Makefile.am 2005-02-01 00:00:00.000000000 +0100
++++ openpam-20050201-gentoo/lib/Makefile.am 2005-06-11 12:48:19.038207056 +0200
+@@ -46,6 +46,7 @@
+ pam_verror.c \
+ pam_vinfo.c \
+ pam_vprompt.c \
++ pam_debug_log.c \
+ $(NULL)
+
+ libpam_la_LDFLAGS = -no-undefined -version-info @LIB_MAJ@ @DL_LIBS@
+diff -Nur openpam-20050201/lib/openpam_dynamic.c openpam-20050201-gentoo/lib/openpam_dynamic.c
+diff -Nur openpam-20050201/lib/pam_debug_log.c openpam-20050201-gentoo/lib/pam_debug_log.c
+--- openpam-20050201/lib/pam_debug_log.c 1970-01-01 01:00:00.000000000 +0100
++++ openpam-20050201-gentoo/lib/pam_debug_log.c 2005-06-11 12:55:17.688562528 +0200
+@@ -0,0 +1,64 @@
++/*-
++ * Copyright 2001 Mark R V Murray
++ * All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ */
++
++#include <sys/cdefs.h>
++
++#ifndef __GLIBC__
++#include <libgen.h>
++#endif
++
++#include <stdarg.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++
++#include <security/pam_appl.h>
++#include <security/openpam.h>
++#include <security/pam_mod_misc.h>
++
++/* Print a verbose error, including the function name and a
++ * cleaned up filename.
++ */
++void
++_pam_verbose_error(pam_handle_t *pamh, int flags,
++ const char *file, const char *function, const char *format, ...)
++{
++ va_list ap;
++ char *fmtbuf, *modname, *period;
++
++ if (!(flags & PAM_SILENT) && !openpam_get_option(pamh, "no_warn")) {
++ modname = basename(file);
++ period = strchr(modname, '.');
++ if (period == NULL)
++ period = strchr(modname, '\0');
++ va_start(ap, format);
++ asprintf(&fmtbuf, "%.*s: %s: %s\n", (int)(period - modname),
++ modname, function, format);
++ pam_verror(pamh, fmtbuf, ap);
++ free(fmtbuf);
++ va_end(ap);
++ }
++}
diff --git a/sys-auth/openpam/openpam-20071221.ebuild b/sys-auth/openpam/openpam-20071221.ebuild
new file mode 100644
index 000000000000..f81ced7d1455
--- /dev/null
+++ b/sys-auth/openpam/openpam-20071221.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20071221.ebuild,v 1.1 2008/03/29 00:46:59 flameeyes Exp $
+
+inherit multilib flag-o-matic autotools
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug vim-syntax"
+
+RDEPEND="!virtual/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+PROVIDE="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
+ epatch "${FILESDIR}/${PN}-20050616-redef.patch"
+ epatch "${FILESDIR}/${PN}-20050616-optional.patch"
+
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --with-modules-dir=/$(get_libdir)/security \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc CREDITS HISTORY MANIFEST RELNOTES README
+}