summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-29 01:50:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-29 01:50:09 +0000
commitc0eaffcd737bc20a34c900f386810d749a2cbe2f (patch)
treee405c234943957b92fbcd40298fd4098ff987b55 /sys-auth/nss_ldap
parentBump to autotool the package, which makes the build work much better in paral... (diff)
downloadgentoo-2-c0eaffcd737bc20a34c900f386810d749a2cbe2f.tar.gz
gentoo-2-c0eaffcd737bc20a34c900f386810d749a2cbe2f.tar.bz2
gentoo-2-c0eaffcd737bc20a34c900f386810d749a2cbe2f.zip
Version bump, potential fix for group stuff from bug #127214 and #97618.
(Portage version: 2.1_rc3)
Diffstat (limited to 'sys-auth/nss_ldap')
-rw-r--r--sys-auth/nss_ldap/ChangeLog7
-rw-r--r--sys-auth/nss_ldap/files/digest-nss_ldap-2503
-rw-r--r--sys-auth/nss_ldap/nss_ldap-250.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index 81ba35257e2e..6e59f1557997 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/nss_ldap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.20 2006/05/25 20:12:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.21 2006/05/29 01:50:09 robbat2 Exp $
+
+*nss_ldap-250 (29 May 2006)
+
+ 29 May 2006; Robin H. Johnson <robbat2@gentoo.org> +nss_ldap-250.ebuild:
+ Version bump, potential fix for group stuff from bug #127214 and #97618.
25 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> nss_ldap-249.ebuild:
Stable on x86 wrt bug #132550.
diff --git a/sys-auth/nss_ldap/files/digest-nss_ldap-250 b/sys-auth/nss_ldap/files/digest-nss_ldap-250
new file mode 100644
index 000000000000..04f7f1e0783b
--- /dev/null
+++ b/sys-auth/nss_ldap/files/digest-nss_ldap-250
@@ -0,0 +1,3 @@
+MD5 ac1bcdaf0765b57b7d9023aa9cd07fb6 nss_ldap-250.tar.gz 240122
+RMD160 52a27c0282d43c0b4e291dceaeeac7fcf43d8ece nss_ldap-250.tar.gz 240122
+SHA256 555c8fc9585478bc31b25349469685fbb6036cc6895e3761731c2c0e7accf2f0 nss_ldap-250.tar.gz 240122
diff --git a/sys-auth/nss_ldap/nss_ldap-250.ebuild b/sys-auth/nss_ldap/nss_ldap-250.ebuild
new file mode 100644
index 000000000000..b4ae9d841c85
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-250.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-250.ebuild,v 1.1 2006/05/29 01:50:09 robbat2 Exp $
+
+inherit fixheadtails eutils gnuconfig multilib
+
+IUSE="debug"
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/nsswitch.ldap.diff
+ epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
+ epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
+ # fix head/tail stuff
+ ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ # fix build borkage
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ ${S}/$i
+ done
+ # update config.{guess,sub}
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debugging"
+
+ econf \
+ --with-ldap-lib=openldap \
+ --libdir=/$(get_libdir) \
+ --enable-schema-mapping \
+ --enable-paged-results \
+ --enable-rfc2307bis \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /$(get_libdir)
+
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ COPYING CVSVersionInfo.txt README nsswitch.ldap certutil
+ docinto docs; dodoc doc/*
+}