summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:43:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:43:04 +0000
commit00685c96f3a3a96831fc261eca672e0f9afc9627 (patch)
tree838ba16fb5758b396c187d0ef1bc9bcd1cb74b23 /sys-auth/nss_ldap
parentFix quoting for all ebuilds. (diff)
downloadgentoo-2-00685c96f3a3a96831fc261eca672e0f9afc9627.tar.gz
gentoo-2-00685c96f3a3a96831fc261eca672e0f9afc9627.tar.bz2
gentoo-2-00685c96f3a3a96831fc261eca672e0f9afc9627.zip
Upstream minor version bump, fixes Kerberos issues for bug #165638 and upstream integrated the skipmembers patch.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-auth/nss_ldap')
-rw-r--r--sys-auth/nss_ldap/ChangeLog8
-rw-r--r--sys-auth/nss_ldap/files/digest-nss_ldap-257.23
-rw-r--r--sys-auth/nss_ldap/nss_ldap-257.2.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index ebdf28a7a470..f8f9b60a0ee4 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/nss_ldap
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.42 2007/10/09 23:39:47 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.43 2007/10/09 23:43:03 robbat2 Exp $
+
+*nss_ldap-257.2 (09 Oct 2007)
+
+ 09 Oct 2007; Robin H. Johnson <robbat2@gentoo.org> +nss_ldap-257.2.ebuild:
+ Upstream minor version bump, fixes Kerberos issues for bug #165638 and
+ upstream integrated the skipmembers patch.
09 Oct 2007; Robin H. Johnson <robbat2@gentoo.org> nss_ldap-239-r1.ebuild,
nss_ldap-249.ebuild, nss_ldap-250.ebuild, nss_ldap-250-r1.ebuild,
diff --git a/sys-auth/nss_ldap/files/digest-nss_ldap-257.2 b/sys-auth/nss_ldap/files/digest-nss_ldap-257.2
new file mode 100644
index 000000000000..7936c05b797e
--- /dev/null
+++ b/sys-auth/nss_ldap/files/digest-nss_ldap-257.2
@@ -0,0 +1,3 @@
+MD5 031878bfbd68c6a85043ab312170f83d nss_ldap-257.2.tar.gz 274699
+RMD160 b27f4509335b7eb026e32458689c01072448093f nss_ldap-257.2.tar.gz 274699
+SHA256 7850f40208d1d3dd946e0c9388e7420ef07f69855fd2721fd2784f3cdb5b82fb nss_ldap-257.2.tar.gz 274699
diff --git a/sys-auth/nss_ldap/nss_ldap-257.2.ebuild b/sys-auth/nss_ldap/nss_ldap-257.2.ebuild
new file mode 100644
index 000000000000..7c0e79ab9182
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-257.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-257.2.ebuild,v 1.1 2007/10/09 23:43:03 robbat2 Exp $
+
+inherit fixheadtails eutils multilib
+
+IUSE="debug sasl kerberos"
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !<net-fs/autofs-4.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ # Applied by upstream
+ #epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
+ # Applied by upstream
+ #EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-257-nss_max_group_depth.patch
+ sed -i.orig \
+ -e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
+ # fix head/tail stuff
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
+ # fix build borkage
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ "${S}"/$i
+ done
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debugging"
+ use kerberos && myconf="${myconf} --enable-configurable-krb5-ccname-gssapi"
+ econf \
+ --with-ldap-lib=openldap \
+ --libdir=/$(get_libdir) \
+ --enable-schema-mapping \
+ --enable-paged-results \
+ --enable-rfc2307bis \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /$(get_libdir)
+
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ COPYING CVSVersionInfo.txt README nsswitch.ldap certutil
+ docinto docs; dodoc doc/*
+}