summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-08 21:46:41 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-08 21:46:41 +0000
commit111ffa6ebde6bcc53e7696b46796ed985d5772d5 (patch)
tree7235f3f84c025539d60b83fa138ee269bef361b0 /sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild
parentx86 stable per bug 402011 (diff)
downloadgentoo-2-111ffa6ebde6bcc53e7696b46796ed985d5772d5.tar.gz
gentoo-2-111ffa6ebde6bcc53e7696b46796ed985d5772d5.tar.bz2
gentoo-2-111ffa6ebde6bcc53e7696b46796ed985d5772d5.zip
New ebuild for an nss module that ensures the system's hostname is always resolvable.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild')
-rw-r--r--sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild b/sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild
new file mode 100644
index 000000000000..9d7ac8b9493b
--- /dev/null
+++ b/sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-myhostname/nss-myhostname-0.3.ebuild,v 1.1 2012/02/08 21:46:41 tetromino Exp $
+
+EAPI="4"
+
+DESCRIPTION="Name Service Switch module for resolving the local hostname"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-myhostname/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # The documentation in doc/ is just the README file in other formats
+ sed -e 's:SUBDIRS *= *doc:SUBDIRS =:' -i Makefile.{am,in} ||
+ die "sed failed"
+}
+
+src_configure() {
+ econf --disable-lynx
+}
+
+pkg_postinst() {
+ elog "You must modify your name service switch lookup file to enable"
+ elog "nss-myhostname. To do so, add 'myhostname' to the hosts line in"
+ elog "/etc/nsswitch.conf"
+ elog
+ elog "An example hosts line looks like this:"
+ elog "hosts: files dns myhostname"
+ elog
+}