summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-06 19:58:03 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-06 19:58:03 +0000
commitd6807a6008f60687edc1b4e21d39c220dd2b3089 (patch)
treea247cf2bbe50a0a06ce6fd3638ef4fd3848c5574 /sys-auth/libnss-cache
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-d6807a6008f60687edc1b4e21d39c220dd2b3089.tar.gz
gentoo-2-d6807a6008f60687edc1b4e21d39c220dd2b3089.tar.bz2
gentoo-2-d6807a6008f60687edc1b4e21d39c220dd2b3089.zip
Version bump (euscan)
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/libnss-cache')
-rw-r--r--sys-auth/libnss-cache/ChangeLog9
-rw-r--r--sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-auth/libnss-cache/ChangeLog b/sys-auth/libnss-cache/ChangeLog
index 9256d44dad87..fda6464b0d5b 100644
--- a/sys-auth/libnss-cache/ChangeLog
+++ b/sys-auth/libnss-cache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/libnss-cache
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-cache/ChangeLog,v 1.7 2011/05/29 16:03:46 idl0r Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-cache/ChangeLog,v 1.8 2012/10/06 19:58:03 xmw Exp $
+
+*libnss-cache-0.10.2 (06 Oct 2012)
+
+ 06 Oct 2012; Michael Weber <xmw@gentoo.org> +libnss-cache-0.10.2.ebuild:
+ Version bump (euscan)
*libnss-cache-0.10.1 (29 May 2011)
diff --git a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
new file mode 100644
index 000000000000..3d6017c82c65
--- /dev/null
+++ b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild,v 1.1 2012/10/06 19:58:03 xmw Exp $
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="libnss-cache is a library that serves nss lookups."
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="multilib"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10.1-make.patch
+ epatch "${FILESDIR}"/${PN}-0.10-fix-shadow-test.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nss_cache || die
+ if use multilib && has_multilib_profile; then
+ emake CC="$(tc-getCC)" nss_cache32 || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die
+ if use multilib && has_multilib_profile; then
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install32 || die
+ fi
+}