summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-06-21 20:38:24 +0000
committerBen de Groot <yngwin@gentoo.org>2008-06-21 20:38:24 +0000
commit73b4c7d29a3c7ddc404f4a6e2e1b456061bf00d2 (patch)
tree8ef9835f690b6024366affcab8917aa03adcfdda /sys-auth/consolekit
parentI meant ~ppc64, not ppc64.. (diff)
downloadgentoo-2-73b4c7d29a3c7ddc404f4a6e2e1b456061bf00d2.tar.gz
gentoo-2-73b4c7d29a3c7ddc404f4a6e2e1b456061bf00d2.tar.bz2
gentoo-2-73b4c7d29a3c7ddc404f4a6e2e1b456061bf00d2.zip
Version bump. Fixes compilation with glibc-2.8, bug 225405.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-hh5 i686)
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/ChangeLog9
-rw-r--r--sys-auth/consolekit/consolekit-0.2.10.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 8bd2f5e3772c..b019009e206f 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/consolekit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.32 2007/12/06 22:15:06 beandog Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.33 2008/06/21 20:38:24 yngwin Exp $
+
+*consolekit-0.2.10 (21 Jun 2008)
+
+ 21 Jun 2008; Ben de Groot <yngwin@gentoo.org> +consolekit-0.2.10.ebuild:
+ Version bump. Fixes compilation with glibc-2.8, bug 225405.
06 Dec 2007; Steve Dibb <beandog@gentoo.org> consolekit-0.2.3.ebuild:
amd64 stable, bug 201103
diff --git a/sys-auth/consolekit/consolekit-0.2.10.ebuild b/sys-auth/consolekit/consolekit-0.2.10.ebuild
new file mode 100644
index 000000000000..77c368e9de8d
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.2.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.2.10.ebuild,v 1.1 2008/06/21 20:38:24 yngwin Exp $
+
+inherit eutils autotools multilib pam
+
+MY_PN="ConsoleKit"
+MY_PV="${PV//_pre*/}"
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://people.freedesktop.org/~mccann/dist/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86 ~x86-fbsd"
+IUSE="debug pam"
+
+# Not parallel make safe
+MAKEOPTS="$MAKEOPTS -j1"
+
+RDEPEND=">=dev-libs/glib-2.7
+ >=dev-libs/dbus-glib-0.61
+ >=x11-libs/libX11-1.0.0
+ pam? ( virtual/pam )
+ elibc_glibc? ( !=sys-libs/glibc-2.4* )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Work around an apparent FreeBSD kernel bug
+ use x86-fbsd && epatch "${FILESDIR}/${PN}"-0.2.3-freebsd.patch
+}
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable pam pam-module) \
+ --with-pam-module-dir=/$(getpam_mod_dir) \
+ --with-pid-file=/var/run/consolekit.pid \
+ --with-dbus-services=/usr/share/dbus-1/services/ \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ #crappy Redhat init script
+ rm -f "${D}/etc/rc.d/init.d/ConsoleKit"
+ rm -r "${D}/etc/rc.d/"
+
+ #Portage barfs on .la files
+ rm -f "${D}/$(get_libdir)/security/pam_ck_connector.la"
+
+ # Gentoo style init script
+ newinitd "${FILESDIR}"/${PN}-0.1.rc consolekit
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You need to restart ConsoleKit to get the new features."
+ ewarn "This can be done with /etc/init.d/consolekit restart"
+ ewarn "but make sure you do this and then restart your session"
+ ewarn "otherwise you will get access denied for certain actions"
+ ewarn
+}