summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-12-18 05:05:03 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-12-18 05:05:03 +0000
commitfe1396277cd567699d09a6d45c8b7bccaa89c548 (patch)
treeaa8bc93329f6503ea40ceda0ba8ce48b79262b97 /sys-apps
parentversion bump (diff)
downloadgentoo-2-fe1396277cd567699d09a6d45c8b7bccaa89c548.tar.gz
gentoo-2-fe1396277cd567699d09a6d45c8b7bccaa89c548.tar.bz2
gentoo-2-fe1396277cd567699d09a6d45c8b7bccaa89c548.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/rigo-daemon/ChangeLog7
-rw-r--r--sys-apps/rigo-daemon/rigo-daemon-254.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-apps/rigo-daemon/ChangeLog b/sys-apps/rigo-daemon/ChangeLog
index 01b0be6e6aad..e29d890d479d 100644
--- a/sys-apps/rigo-daemon/ChangeLog
+++ b/sys-apps/rigo-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rigo-daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/ChangeLog,v 1.11 2013/08/22 14:53:52 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/ChangeLog,v 1.12 2013/12/18 05:05:03 lxnay Exp $
+
+*rigo-daemon-254 (18 Dec 2013)
+
+ 18 Dec 2013; Fabio Erculiani <lxnay@gentoo.org> +rigo-daemon-254.ebuild:
+ version bump
22 Aug 2013; Fabio Erculiani <lxnay@gentoo.org> -rigo-daemon-189.ebuild:
drop older version 189
diff --git a/sys-apps/rigo-daemon/rigo-daemon-254.ebuild b/sys-apps/rigo-daemon/rigo-daemon-254.ebuild
new file mode 100644
index 000000000000..bedf4d737610
--- /dev/null
+++ b/sys-apps/rigo-daemon/rigo-daemon-254.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/rigo-daemon-254.ebuild,v 1.1 2013/12/18 05:05:03 lxnay Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+MY_PN="RigoDaemon"
+DESCRIPTION="Entropy Client DBus Services, aka RigoDaemon"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}/rigo/${MY_PN}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python
+ dev-python/pygobject:3
+ ~sys-apps/entropy-${PV}[${PYTHON_USEDEP}]
+ sys-auth/polkit[introspection]
+ sys-devel/gettext"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ python_optimize "${D}/usr/lib/rigo/${MY_PN}"
+}
+
+pkg_preinst() {
+ # ask RigoDaemon to shutdown, if running
+ # TODO: this will be removed in future
+ local shutdown_exec=${EROOT}/usr/lib/rigo/${MY_PN}/shutdown.py
+ [[ -x "${shutdown_exec}" ]] && "${shutdown_exec}"
+}