summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-01-06 17:19:37 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-01-06 17:19:37 +0000
commitf6a3c48f628724f87fdce42de893dbb4de4729d8 (patch)
treef9dce6eeec4071625901b3c9993bd3597f987ae6 /sys-apps
parentAdd upstream node. (diff)
downloadgentoo-2-f6a3c48f628724f87fdce42de893dbb4de4729d8.tar.gz
gentoo-2-f6a3c48f628724f87fdce42de893dbb4de4729d8.tar.bz2
gentoo-2-f6a3c48f628724f87fdce42de893dbb4de4729d8.zip
Version bump, per bug#450600
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-tools/ChangeLog10
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.4.21.ebuild70
2 files changed, 77 insertions, 3 deletions
diff --git a/sys-apps/pcsc-tools/ChangeLog b/sys-apps/pcsc-tools/ChangeLog
index 9eeaeb437fb5..8c301dbacf01 100644
--- a/sys-apps/pcsc-tools/ChangeLog
+++ b/sys-apps/pcsc-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-tools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-tools/ChangeLog,v 1.14 2012/06/16 16:07:15 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-tools/ChangeLog,v 1.15 2013/01/06 17:19:37 alonbl Exp $
+
+*pcsc-tools-1.4.21 (06 Jan 2013)
+
+ 06 Jan 2013; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-tools-1.4.21.ebuild:
+ Version bump, per bug#450600
*pcsc-tools-1.4.20 (16 Jun 2012)
@@ -102,4 +107,3 @@
Tested with a USB smartcard reader (Axalto Reflex USB v3). The older
reader I tried (mentioned on several forum posts) won't work without
a firmware update.
-
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.4.21.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.4.21.ebuild
new file mode 100644
index 000000000000..1271bc9bf673
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.4.21.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-tools/pcsc-tools-1.4.21.ebuild,v 1.1 2013/01/06 17:19:37 alonbl Exp $
+
+EAPI="4"
+
+inherit eutils fdo-mime multilib toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz
+ ${SC_REV:+http://anonscm.debian.org/viewvc/pcsclite/trunk/pcsc-tools/smartcard_list.txt?revision=${SC_REV}&view=co -> ${PN}-smartcard_list-${SC_REV}.txt}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/gtk2-perl )"
+
+src_prepare() {
+ sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ dodoc README Changelog
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ if [[ -n ${SC_REV} ]]; then
+ newins "${WORKDIR}"/${PN}-smartcard_list-${SC_REV}.txt smartcard_list.txt
+ else
+ doins smartcard_list.txt
+ fi
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}