summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-11 22:54:12 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-11 22:54:12 +0000
commitf4a716b69ac2fb4b8411d3ca2025c8e479c57574 (patch)
tree14fba9569af63883e58a9d2c9876d7c2b9bd8cbf /sys-apps
parentPorting patches to 1.2.9-r1 closing bug#98536 (diff)
downloadgentoo-2-f4a716b69ac2fb4b8411d3ca2025c8e479c57574.tar.gz
gentoo-2-f4a716b69ac2fb4b8411d3ca2025c8e479c57574.tar.bz2
gentoo-2-f4a716b69ac2fb4b8411d3ca2025c8e479c57574.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.4.33
-rw-r--r--sys-apps/rlocate/files/rlocate-0.4.3-build.patch33
-rw-r--r--sys-apps/rlocate/rlocate-0.4.3.ebuild48
4 files changed, 91 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index d3c46bfb0a10..e863cafb1ae9 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.11 2006/01/20 23:07:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.12 2006/02/11 22:54:12 vapier Exp $
+
+*rlocate-0.4.3 (11 Feb 2006)
+
+ 11 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.4.3-build.patch, +rlocate-0.4.3.ebuild:
+ Version bump.
*rlocate-0.4.2 (20 Jan 2006)
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.4.3 b/sys-apps/rlocate/files/digest-rlocate-0.4.3
new file mode 100644
index 000000000000..286bf8d87367
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.4.3
@@ -0,0 +1,3 @@
+MD5 2cd397aec03c600e0489f98d5aaff9c5 rlocate-0.4.3.tar.gz 194748
+RMD160 579cad66cd7ca5da7d4d790d1ffd914fd2c1a66a rlocate-0.4.3.tar.gz 194748
+SHA256 1c24eb74698f4dba07e4c2d28e4f81506a195e1a435f2e92c9510bdf956947cd rlocate-0.4.3.tar.gz 194748
diff --git a/sys-apps/rlocate/files/rlocate-0.4.3-build.patch b/sys-apps/rlocate/files/rlocate-0.4.3-build.patch
new file mode 100644
index 000000000000..82e2f7d89f78
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.4.3-build.patch
@@ -0,0 +1,33 @@
+--- Makefile.in
++++ Makefile.in
+@@ -209,7 +209,7 @@
+
+ rlocate_SOURCES = pidfile.h pidfile.c main.c link.c misc.c link.h \
+ misc.h rlocate.h rlocate.c $(am__append_1)
+-SUBDIRS = doc rlocate-daemon rlocate-module rlocate-scripts
++SUBDIRS = doc rlocate-daemon rlocate-scripts
+ EXTRA_DIST = rlocate.cron debian rlocate-scripts autogen.sh \
+ contrib install-cron.sh.in ChangeLog.slocate
+
+--- rlocate-daemon/Makefile.in
++++ rlocate-daemon/Makefile.in
+@@ -172,7 +172,7 @@
+ -DRLOCATE_GRP=\"$(rlocate_group)\"
+
+ rlocated_SOURCES = ../misc.h ../misc.c ../pidfile.h ../pidfile.c rlocated.c
+-AM_CFLAGS = -O2 -Wall
++AM_CFLAGS = -Wall
+ all: all-am
+
+ .SUFFIXES:
+--- rlocate-scripts/Makefile.in
++++ rlocate-scripts/Makefile.in
+@@ -344,8 +344,6 @@
+ rm $(srcdir)/rlocate-checkpoint.temp
+
+ install-exec-hook:
+-@FREEBSD_TRUE@ -/usr/sbin/pw groupadd $(rlocate_group)
+-@FREEBSD_FALSE@ -/usr/sbin/groupadd $(rlocate_group)
+ chown $(root_uid):$(rlocate_group) $(DESTDIR)$(bindir)/rlocate-checkpoint
+ chmod 2755 $(DESTDIR)$(bindir)/rlocate-checkpoint
+
diff --git a/sys-apps/rlocate/rlocate-0.4.3.ebuild b/sys-apps/rlocate/rlocate-0.4.3.ebuild
new file mode 100644
index 000000000000..6c85e95d1e95
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.4.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.4.3.ebuild,v 1.1 2006/02/11 22:54:12 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4.3-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}