summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-06-03 15:03:31 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-06-03 15:03:31 +0000
commitf3ff65403cb549e0ad5a616c455cfa0de295b966 (patch)
tree811c9e7a4843273c352a218412ca8de9e996e085 /sys-apps
parentx86 stable wrt bug #311357 (diff)
downloadgentoo-2-f3ff65403cb549e0ad5a616c455cfa0de295b966.tar.gz
gentoo-2-f3ff65403cb549e0ad5a616c455cfa0de295b966.tar.bz2
gentoo-2-f3ff65403cb549e0ad5a616c455cfa0de295b966.zip
Version bump to 0.9.2. Add several new useflags. Use internal _flashrom_enable() function to enable/disable features. Update metadata.xml. Add myself as maintainer.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/flashrom/ChangeLog10
-rw-r--r--sys-apps/flashrom/flashrom-0.9.1.ebuild53
-rw-r--r--sys-apps/flashrom/flashrom-0.9.2.ebuild78
-rw-r--r--sys-apps/flashrom/metadata.xml46
4 files changed, 116 insertions, 71 deletions
diff --git a/sys-apps/flashrom/ChangeLog b/sys-apps/flashrom/ChangeLog
index 5707418a74da..7c48a634fc1b 100644
--- a/sys-apps/flashrom/ChangeLog
+++ b/sys-apps/flashrom/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/flashrom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/flashrom/ChangeLog,v 1.3 2010/01/28 20:04:28 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/flashrom/ChangeLog,v 1.4 2010/06/03 15:03:31 idl0r Exp $
+
+*flashrom-0.9.2 (03 Jun 2010)
+
+ 03 Jun 2010; Christian Ruppert <idl0r@gentoo.org> -flashrom-0.9.1.ebuild,
+ +flashrom-0.9.2.ebuild, metadata.xml:
+ Version bump to 0.9.2. Add several new useflags. Use internal
+ _flashrom_enable() function to enable/disable features. Update
+ metadata.xml. Add myself as maintainer.
*flashrom-0.9.1 (28 Jan 2010)
diff --git a/sys-apps/flashrom/flashrom-0.9.1.ebuild b/sys-apps/flashrom/flashrom-0.9.1.ebuild
deleted file mode 100644
index 54727cd8b9ec..000000000000
--- a/sys-apps/flashrom/flashrom-0.9.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/flashrom/flashrom-0.9.1.ebuild,v 1.1 2010/01/28 20:04:28 idl0r Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Utility for reading, writing, erasing and verifying flash ROM chips"
-HOMEPAGE="http://flashrom.org"
-SRC_URI="http://qa.coreboot.org/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ftdi serprog"
-
-RDEPEND="sys-apps/pciutils
- ftdi? ( dev-embedded/libftdi )"
-DEPEND="${RDEPEND}
- sys-apps/sed"
-
-src_prepare() {
- # We don't need zlib here
- # Disable auto-deps
- sed -i -e 's:^LIBS +=.*:LIBS += -lpci:' \
- -e 's/^all:.*/all: dep $(PROGRAM)/' \
- -e 's/^\.features:.*/\.features:/' \
- Makefile || die
-}
-
-src_compile() {
- if use ftdi;
- then
- append-cflags "-DFT2232_SPI_SUPPORT=1"
- export LIBS="-lftdi"
- fi
- if use serprog;
- then
- append-cflags "-DSERPROG_SUPPORT=1"
- fi
-
- # Get a rid of "grep: .features: No such file or directory" warnings
- touch .features
-
- emake CC="$(tc-getCC)" STRIP="" || die "emake failed"
-}
-
-src_install() {
- dosbin flashrom || die
- doman flashrom.8 || die
- dodoc ChangeLog README
-}
diff --git a/sys-apps/flashrom/flashrom-0.9.2.ebuild b/sys-apps/flashrom/flashrom-0.9.2.ebuild
new file mode 100644
index 000000000000..86889d1267c6
--- /dev/null
+++ b/sys-apps/flashrom/flashrom-0.9.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/flashrom/flashrom-0.9.2.ebuild,v 1.1 2010/06/03 15:03:31 idl0r Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for reading, writing, erasing and verifying flash ROM chips"
+HOMEPAGE="http://flashrom.org"
+SRC_URI="http://qa.coreboot.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="buspiratespi drkaiser dummy ftdi +internal nic3com nvidia satasii serprog wiki"
+
+COMMON_DEPEND="drkaiser? ( sys-apps/pciutils )
+ internal? ( sys-apps/pciutils )
+ nic3com? ( sys-apps/pciutils )
+ nvidia? ( sys-apps/pciutils )
+ satasii? ( sys-apps/pciutils )
+ ftdi? ( dev-embedded/libftdi )"
+RDEPEND="${COMMON_DEPEND}
+ internal? ( sys-apps/dmidecode )"
+DEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+
+_flashrom_enable() {
+ local flag=${1}
+ local macro=${2}
+
+ if use $flag; then
+ args="${args} ${macro}=yes"
+ else
+ args="${args} ${macro}=no"
+ fi
+}
+
+src_compile() {
+ local progs=0
+ local args=""
+
+ _flashrom_enable buspiratespi CONFIG_BUSPIRATESPI
+ _flashrom_enable drkaiser CONFIG_DRKAISER
+ _flashrom_enable dummy CONFIG_DUMMY
+ _flashrom_enable ftdi CONFIG_FT2232SPI
+ _flashrom_enable internal CONFIG_INTERNAL
+ _flashrom_enable nic3com CONFIG_NIC3COM
+ _flashrom_enable nvidia CONFIG_GFXNVIDIA
+ _flashrom_enable satasii CONFIG_SATASII
+ _flashrom_enable serprog CONFIG_SERPROG
+
+ # You have to specify at least one programmer, and if you specify more than
+ # one programmer you have to include either dummy or internal in the list.
+ for prog in buspiratespi drkaiser ftdi nic3com nvidia satasii serprog;
+ do
+ use $prog && progs=$((progs + 1))
+ done
+ if [ $progs -ne 1 ]; then
+ if ! use internal && ! use dummy; then
+ ewarn "You have to specify at least one programmer,"
+ ewarn "and if you specify more than one programmer you have to enable"
+ ewarn "either dummy or internal as well"
+ ewarn "'internal' will be the default now"
+ sleep 3
+ args="${args} CONFIG_INTERNAL=yes"
+ fi
+ fi
+
+ emake CC="$(tc-getCC)" ${args} || die
+}
+
+src_install() {
+ dosbin flashrom || die
+ doman flashrom.8
+ dodoc ChangeLog README
+}
diff --git a/sys-apps/flashrom/metadata.xml b/sys-apps/flashrom/metadata.xml
index e94021f7f8b2..15aae63020e4 100644
--- a/sys-apps/flashrom/metadata.xml
+++ b/sys-apps/flashrom/metadata.xml
@@ -1,22 +1,34 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
- <email>leio@gentoo.org</email>
-</maintainer>
-<maintainer>
- <email>peter@stuge.se</email>
- <description>Please CC on all bugs</description>
-</maintainer>
-<use>
- <flag name="ftdi">Enable flashing through FTDI/SPI USB interface</flag>
- <flag name="serprog">Enable Serial Flasher support</flag>
-</use>
-<longdescription lang="en">
-flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips. It's often used to flash BIOS/EFI/coreboot/firmware images.
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>leio@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <maintainer>
+ <email>peter@stuge.se</email>
+ <description>Please CC on all bugs</description>
+ </maintainer>
+ <use>
+ <flag name="buspiratespi">Enable Bus Pirate SPI programmer</flag>
+ <flag name="drkaiser">Enable Dr. Kaiser programmer</flag>
+ <flag name="dummy">Enable dummy tracing</flag>
+ <flag name="ftdi">Enable ftdi programmer, flashing through FTDI/SPI USB interface</flag>
+ <flag name="internal">Enable internal/onboard support</flag>
+ <flag name="nic3com">Enable 3Com NIC programmer</flag>
+ <flag name="nvidia">Enable NVIDIA programmer</flag>
+ <flag name="satasii">Enable programmer for SiI SATA controllers</flag>
+ <flag name="serprog">Enable Serial Flasher programmer</flag>
+ <flag name="wiki">Enable wiki informations, like supported devices etc.</flag>
+ </use>
+ <longdescription lang="en">
+flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips. It is designed to flash BIOS/EFI/coreboot/firmware/optionROM images on mainboards, network/graphics/storage controller cards, and various programmer devices.
- * Supports more than 195 flash chips, 75 chipsets, 130 mainboards, and 17 devices (PCI or USB) which can be used as external programmers.
+ * Supports more than 225 flash chips, 128 chipsets, 186 mainboards, 19 PCI devices, 3 USB devices and all external programmers which use the serprog protocol.
* Supports parallel, LPC, FWH and SPI flash interfaces and various chip packages (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, TSOP40, TSOP48, and more)
* No physical access needed, root access is sufficient.
* No bootable floppy disk, bootable CD-ROM or other media needed.
@@ -25,6 +37,6 @@ flashrom is a utility for identifying, reading, writing, verifying and erasing f
* Crossflashing and hotflashing is possible as long as the flash chips are electrically and logically compatible (same protocol). Great for recovery.
* Scriptability. Reflash a whole pool of identical machines at the same time from the command line. It is recommended to check flashrom output and error codes.
* Speed. flashrom is often much faster than most vendor flash tools.
- * Portability. Supports Linux, FreeBSD, DragonFly BSD, Solaris, Mac OS X, and other Unix-like OSes.
-</longdescription>
+ * Portability. Supports DOS, Linux, FreeBSD, NetBSD, DragonFly BSD, Solaris, Mac OS X, and other Unix-like OSes. Partial Windows support is available (full support as patch).
+ </longdescription>
</pkgmetadata>