summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-10-24 18:32:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-10-24 18:32:35 +0000
commitf2c7ca0a49fee22268dfb3cdb3a64691bd8f45bd (patch)
tree27949adfe39cc3dcac2c2df26ec47633c9a51701 /sys-apps
parentMask map empathy USE flag on (previously missed) arches due missing keywords,... (diff)
downloadgentoo-2-f2c7ca0a49fee22268dfb3cdb3a64691bd8f45bd.tar.gz
gentoo-2-f2c7ca0a49fee22268dfb3cdb3a64691bd8f45bd.tar.bz2
gentoo-2-f2c7ca0a49fee22268dfb3cdb3a64691bd8f45bd.zip
Set the active Python to 2.x since this doesn't build with 3.x
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/seabios/ChangeLog6
-rw-r--r--sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/seabios/ChangeLog b/sys-apps/seabios/ChangeLog
index 5efb9d4b3bd6..202576ef728a 100644
--- a/sys-apps/seabios/ChangeLog
+++ b/sys-apps/seabios/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/seabios
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.3 2011/10/21 16:55:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.4 2011/10/24 18:32:35 cardoe Exp $
+
+ 24 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
+ seabios-0.6.3_pre20010817.ebuild:
+ Set the active Python to 2.x since this doesn't build with 3.x
21 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
seabios-0.6.3_pre20010817.ebuild:
diff --git a/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild b/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild
index 765d63f294de..fa38ea82c893 100644
--- a/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild
+++ b/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild,v 1.5 2011/10/21 16:55:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild,v 1.6 2011/10/24 18:32:35 cardoe Exp $
EAPI=4
@@ -16,7 +16,7 @@ else
${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
fi
-inherit ${GIT_ECLASS}
+inherit ${GIT_ECLASS} python
if [[ ${PV} = *9999* ]]; then
KEYWORDS=""
@@ -36,6 +36,10 @@ RDEPEND="${DEPEND}
!app-emulation/qemu
!<=app-emulation/qemu-kvm-0.15.0"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
if [[ -z "${EGIT_COMMIT}" ]]; then
sed -e "s/VERSION=.*/VERSION=${PV}/" \