summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-21 20:10:31 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-21 20:10:31 +0000
commitf110aae65a65e8a788de2d3acf50af190a7d1d19 (patch)
tree91f4171d790f613d94383a18156f482e4d9f00ef /sys-apps
parentnew package. fixes #3242 (diff)
downloadgentoo-2-f110aae65a65e8a788de2d3acf50af190a7d1d19.tar.gz
gentoo-2-f110aae65a65e8a788de2d3acf50af190a7d1d19.tar.bz2
gentoo-2-f110aae65a65e8a788de2d3acf50af190a7d1d19.zip
moved arch check into src_compile for testing
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
index e1ce4fc12617..83ce2c7d39ba 100644
--- a/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
+++ b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild,v 1.2 2002/06/20 06:19:59 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild,v 1.3 2002/06/21 20:10:31 gerk Exp $
A="hfsplus_1.0.4.src.tar.bz2"
S=${WORKDIR}/hfsplus-1.0.4
@@ -16,12 +16,13 @@ SLOT="0"
MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
-if [ ${ARCH} = "x86" ] ; then
- einfo "Sorry, this is a PPC only utility"
- exit 1
-fi
-
src_compile() {
+ # if not ppc bail
+ if [ ${ARCH} = "x86" ] ; then
+ einfo "Sorry, this is a PPC only utility"
+ exit 1
+ fi
+
# This does a autoconf, automake, etc.
emake -f Makefile.cvs all || die
./configure \