summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-17 12:29:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-17 12:29:44 +0000
commitf069bc77be326ed38fcfe1d21719c67c158f983d (patch)
treef0e59bebe3b49cad878014b3b6bc79a095457cd3 /sys-apps
parentFix insecure temporary file creation (CVE-2005-3342), bug #122705. (diff)
downloadgentoo-2-f069bc77be326ed38fcfe1d21719c67c158f983d.tar.gz
gentoo-2-f069bc77be326ed38fcfe1d21719c67c158f983d.tar.bz2
gentoo-2-f069bc77be326ed38fcfe1d21719c67c158f983d.zip
Make sure $WORKDIR is go-w before giving everyone read access #122951 by Joshua Pettett.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog8
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r6.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r7.ebuild3
-rw-r--r--sys-apps/coreutils/coreutils-5.3.0-r1.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-5.3.0-r2.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-5.93.ebuild3
-rw-r--r--sys-apps/coreutils/coreutils-5.94.ebuild3
7 files changed, 22 insertions, 10 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 4d9e7e661272..1db832e55731 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.155 2006/02/17 02:34:44 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.156 2006/02/17 12:29:43 vapier Exp $
+
+ 17 Feb 2006; Mike Frysinger <vapier@gentoo.org> coreutils-5.2.1-r6.ebuild,
+ coreutils-5.2.1-r7.ebuild, coreutils-5.3.0-r1.ebuild,
+ coreutils-5.3.0-r2.ebuild, coreutils-5.93.ebuild, coreutils-5.94.ebuild:
+ Make sure $WORKDIR is go-w before giving everyone read access #122951 by
+ Joshua Pettett.
17 Feb 2006; Chris PeBenito <pebenito@gentoo.org> coreutils-5.94.ebuild:
Fix up SELinux patch.
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
index be0636c800db..a3b3b8ffa158 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.17 2005/10/29 09:41:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.18 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -109,6 +109,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild
index f5eb3d4b87c4..fbf33b95cdc4 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild,v 1.11 2006/02/09 06:24:47 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild,v 1.12 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -103,6 +103,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"
diff --git a/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild b/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild
index 1ce1f1871701..9f9a31e6335c 100644
--- a/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild,v 1.5 2005/10/29 09:41:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild,v 1.6 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -93,6 +93,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"
diff --git a/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild b/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild
index 0070005a0fe4..c262a28d4541 100644
--- a/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild,v 1.3 2006/01/11 04:29:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild,v 1.4 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -95,6 +95,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"
diff --git a/sys-apps/coreutils/coreutils-5.93.ebuild b/sys-apps/coreutils/coreutils-5.93.ebuild
index 3e2042bca295..1b01e6c27550 100644
--- a/sys-apps/coreutils/coreutils-5.93.ebuild
+++ b/sys-apps/coreutils/coreutils-5.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.93.ebuild,v 1.3 2006/01/29 09:17:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.93.ebuild,v 1.4 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -95,6 +95,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"
diff --git a/sys-apps/coreutils/coreutils-5.94.ebuild b/sys-apps/coreutils/coreutils-5.94.ebuild
index 27476b6846ab..e13fc77a6813 100644
--- a/sys-apps/coreutils/coreutils-5.94.ebuild
+++ b/sys-apps/coreutils/coreutils-5.94.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.94.ebuild,v 1.2 2006/02/17 02:34:44 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.94.ebuild,v 1.3 2006/02/17 12:29:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -94,6 +94,7 @@ src_compile() {
src_test() {
# Non-root tests will fail if the full path isnt
# accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
chmod a+rx "${WORKDIR}"
addwrite /dev/full
export RUN_EXPENSIVE_TESTS="yes"