summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-05 20:06:01 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-05 20:06:01 +0000
commitecdc2e1c2aeca0c89fa44323ad836ca4b485f009 (patch)
tree23c372f9b63f91f17637ea91b191c3813f8baadd /sys-apps
parentAdding perl dep; fixed DEPEND (diff)
downloadgentoo-2-ecdc2e1c2aeca0c89fa44323ad836ca4b485f009.tar.gz
gentoo-2-ecdc2e1c2aeca0c89fa44323ad836ca4b485f009.tar.bz2
gentoo-2-ecdc2e1c2aeca0c89fa44323ad836ca4b485f009.zip
Version bump #142595 by Jac Goudsmit.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog7
-rw-r--r--sys-apps/busybox/busybox-1.2.1.ebuild238
-rw-r--r--sys-apps/busybox/files/digest-busybox-1.2.13
3 files changed, 247 insertions, 1 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 1942ba236673..f0ee05597eb5 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.101 2006/07/10 17:54:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.102 2006/08/05 20:06:01 vapier Exp $
+
+*busybox-1.2.1 (05 Aug 2006)
+
+ 05 Aug 2006; Mike Frysinger <vapier@gentoo.org> +busybox-1.2.1.ebuild:
+ Version bump #142595 by Jac Goudsmit.
10 Jul 2006; <solar@gentoo.org> busybox-1.1.3.ebuild,
busybox-1.2.0.ebuild:
diff --git a/sys-apps/busybox/busybox-1.2.1.ebuild b/sys-apps/busybox/busybox-1.2.1.ebuild
new file mode 100644
index 000000000000..454dd1abe00e
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.2.1.ebuild
@@ -0,0 +1,238 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.1 2006/08/05 20:06:01 vapier Exp $
+
+inherit eutils flag-o-matic
+
+#SNAPSHOT=20040726
+SNAPSHOT=""
+
+DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
+if [[ -n ${SNAPSHOT} ]] ; then
+ MY_P=${PN}
+ SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
+else
+ MY_P=${PN}-${PV/_/-}
+ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug static savedconfig netboot floppyboot make-symlinks"
+RESTRICT="test"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+# <pebenito> then eventually turning on selinux would mean
+# adding a dep: selinux? ( sys-libs/libselinux )
+
+busybox_set_env() {
+ type -p ${CHOST}-ar > /dev/null && export CROSS=${CHOST}-
+ # Don't let KBUILD_OUTPUT mess us up #88088
+ unset KBUILD_OUTPUT
+}
+
+busybox_config_option() {
+ case $1 in
+ y) sed -i -e "s:.*CONFIG_$2.*set:CONFIG_$2=y:g" .config;;
+ n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
+ Y) echo "CONFIG_$2=y" >> .config;;
+ N) echo "CONFIG_$2=n" >> .config;;
+ *) use $1 \
+ && busybox_config_option y $2 \
+ || busybox_config_option n $2
+ return 0
+ ;;
+ esac
+ einfo $(grep "CONFIG_$2[= ]" .config)
+}
+
+src_unpack() {
+ busybox_set_env
+ unpack ${A}
+ cd "${S}"
+
+ # patches go here!
+ epatch "${FILESDIR}"/1.2.0/bb.patch
+
+ # check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
+ # fine grained config control for user defined busybox configs.
+ # [package]-[version]-[revision].config
+ # [package]-[version].config
+ # [package].config
+
+ if use savedconfig ; then
+ local conf root
+ [[ -r .config ]] && rm .config
+ for conf in {${PF},${P},${PN}}{,-${CHOST}} ; do
+ for root in "${ROOT}" / ; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config
+ if [[ -r ${configfile} ]] ; then
+ cp ${configfile} "${S}"/.config
+ break
+ fi
+ done
+ done
+ if [[ -r ${S}/.config ]] ; then
+ einfo "Found your ${configfile} and using it."
+ yes "" | make oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, going with default"
+ yes "" | make oldconfig > /dev/null
+ fi
+ fi
+ if use netboot ; then
+ cp "${FILESDIR}"/config-netboot .config
+ sed -i \
+ -e '/DEFAULT_SCRIPT/s:/share/udhcpc/default.script:/lib/udhcpc.script:' \
+ networking/udhcp/libbb_udhcp.h \
+ || die "fixing netboot/udhcpc"
+ elif use floppyboot ; then
+ cp "${FILESDIR}"/config-floppyboot .config
+ fi
+
+ # setup the config file
+ make allyesconfig > /dev/null
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+ busybox_config_option n BUILD_AT_ONCE
+ busybox_config_option n BUILD_LIBBUSYBOX
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y FEATURE_SH_IS_ASH
+ busybox_config_option n FEATURE_SH_IS_NONE
+
+ busybox_config_option static STATIC
+ busybox_config_option debug DEBUG
+ use debug \
+ && busybox_config_option Y NO_DEBUG_LIB \
+ && busybox_config_option N DMALLOC \
+ && busybox_config_option N EFENCE
+
+ busybox_config_option selinux SELINUX
+
+ # default a bunch of uncommon options to off
+ for opt in LOCALE_SUPPORT TFTP FTP{GET,PUT} IPCALC TFTP HUSH \
+ LASH MSH INETD DPKG RPM2CPIO RPM FOLD LOGNAME OD CRONTAB \
+ UUDECODE UUENCODE SULOGIN DC
+ do
+ busybox_config_option n ${opt}
+ done
+
+ make oldconfig > /dev/null
+}
+
+src_compile() {
+ busybox_set_env
+ use ppc64 && append-flags -mminimal-toc $(test-flags-CC -fno-stack-protector)
+ use ppc && append-flags $(test-flags-CC -fno-stack-protector)
+ emake CROSS="${CROSS}" busybox || die "build failed"
+ if ! use static ; then
+ mv busybox_unstripped{,.bak}
+ local failed=0
+ LDFLAGS="${LDFLAGS} -static" \
+ emake \
+ CROSS="${CROSS}" \
+ busybox || failed=1
+ if [[ ${failed} == 1 ]] ; then
+ if has_version '<sys-libs/glibc-2.3.5' ; then
+ eerror "Your glibc has broken static support, ignorning static build failure."
+ eerror "See http://bugs.gentoo.org/94879"
+ cp busybox_unstripped bb
+ else
+ die "static build failed"
+ fi
+ else
+ mv busybox_unstripped bb
+ fi
+ mv busybox_unstripped{.bak,}
+ fi
+}
+
+src_install() {
+ busybox_set_env
+
+ into /
+ newbin busybox_unstripped busybox || die
+ use static \
+ && dosym busybox /bin/bb \
+ || dobin bb
+
+ if use make-symlinks ; then
+ if [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
+ make CROSS="${CROSS}" install || die
+ cp -pPR _install/${x}/* "${D}"/ || die "copying links for ${x} failed"
+ cd "${D}"
+ # XXX: should really move this to pkg_preinst() ...
+ local symlink
+ for symlink in {,usr/}{bin,sbin}/* linuxrc ; do
+ [[ -L ${symlink} ]] || continue
+ [[ -e ${ROOT}/${symlink} ]] \
+ && eerror "Deleting symlink ${symlink} because it exists in ${ROOT}" \
+ && rm ${symlink}
+ done
+ cd "${S}"
+ fi
+
+ dodoc AUTHORS README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html *.sgml
+
+ # no man files?
+ # cd ../man && doman *.1
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab depmod.pl *.conf *.script undeb unrpm
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ dodoc * etc/* etc/init.d/* 2>/dev/null
+
+ cd ../../ || die
+ if has buildpkg ${FEATURES} && has keepwork ${FEATURES} ; then
+ cd "${S}"
+ # this should install to the ./_install/ dir by default.
+ # we make a micro pkg of busybox that can be used for
+ # embedded systems -solar
+ if ! use make-symlinks ; then
+ make CROSS="${CROSS}" install || die
+ fi
+ cd ./_install/ \
+ && tar --no-same-owner -jcvf ${WORKDIR}/${MY_P}-${ARCH}.bz2 . \
+ && cd ..
+ fi
+
+ if use savedconfig ; then
+ einfo "Saving this build config to /etc/portage/savedconfig/${PVR}.config"
+ einfo "Read this ebuild for more info on how to take advantage of this option"
+ insinto /etc/portage/savedconfig
+ newins "${S}"/.config ${PVR}.config
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ echo
+}
diff --git a/sys-apps/busybox/files/digest-busybox-1.2.1 b/sys-apps/busybox/files/digest-busybox-1.2.1
new file mode 100644
index 000000000000..a951b98249ea
--- /dev/null
+++ b/sys-apps/busybox/files/digest-busybox-1.2.1
@@ -0,0 +1,3 @@
+MD5 362b3dc0f2023ddfda901dc1f1a74391 busybox-1.2.1.tar.bz2 1404986
+RMD160 c9eb1637856a98278a4666f1c27db861477c31ca busybox-1.2.1.tar.bz2 1404986
+SHA256 c6f955c7feafdb7c40645b3dc4c4a3c945477a2429633eef7b2a34ef01827410 busybox-1.2.1.tar.bz2 1404986