summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-11-30 07:57:31 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-11-30 07:57:31 +0000
commite148873e3d2f996c769c520258afe9e438439c13 (patch)
treea1cca230cc99e631ecb730527654a4cfb9e5e043 /sys-apps
parentVersion bump (diff)
downloadgentoo-2-e148873e3d2f996c769c520258afe9e438439c13.tar.gz
gentoo-2-e148873e3d2f996c769c520258afe9e438439c13.tar.bz2
gentoo-2-e148873e3d2f996c769c520258afe9e438439c13.zip
Restore a couple of files needed for 0.5.5.1-r3 that must've been accidentally removed.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/files/hal-0.5.5.1-RBC.patch18
-rw-r--r--sys-apps/hal/files/hal-unmount.dev17
3 files changed, 41 insertions, 1 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 3f7915f35edd..b042e6d9e6d4 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.110 2006/11/20 22:16:30 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.111 2006/11/30 07:57:31 dberkholz Exp $
+
+ 30 Nov 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/hal-0.5.5.1-RBC.patch, +files/hal-unmount.dev:
+ Restore a couple of files needed for 0.5.5.1-r3 that must've been
+ accidentally removed.
20 Nov 2006; Saleem Abdulrasool <compnerd@gentoo.org> hal-0.5.7-r3.ebuild:
Fix dbus dependencies for dbus-1.0 release
diff --git a/sys-apps/hal/files/hal-0.5.5.1-RBC.patch b/sys-apps/hal/files/hal-0.5.5.1-RBC.patch
new file mode 100644
index 000000000000..ce906e3e5ed7
--- /dev/null
+++ b/sys-apps/hal/files/hal-0.5.5.1-RBC.patch
@@ -0,0 +1,18 @@
+Index: hald/linux2/blockdev.c
+===================================================================
+RCS file: /cvs/hal/hal/hald/linux2/blockdev.c,v
+retrieving revision 1.27
+diff -u -3 -p -r1.27 blockdev.c
+--- hald/linux2/blockdev.c 2 Nov 2005 15:38:13 -0000 1.27
++++ hald/linux2/blockdev.c 28 Nov 2005 23:04:24 -0000
+@@ -827,7 +827,8 @@ hotplug_event_begin_add_blockdev (const
+
+ /* These magic values are documented in the kernel source */
+ switch (type) {
+- case 0: /* Disk */
++ case 0: /* Disk */
++ case 14: /* Simple Direct Access Device, set it to disk */
+ hal_device_property_set_string (d, "storage.drive_type", "disk");
+ break;
+
+
diff --git a/sys-apps/hal/files/hal-unmount.dev b/sys-apps/hal/files/hal-unmount.dev
new file mode 100644
index 000000000000..04d1fa81b597
--- /dev/null
+++ b/sys-apps/hal/files/hal-unmount.dev
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+# sanity check. DEVNAME should start with a /
+[ "$DEVNAME" != "${DEVNAME#/}" ] || exit 0
+
+# Lazily unmount drives which are removed, but still mounted
+if [ "$ACTION" = remove ] \
+ && (grep -q "^$DEVNAME" /proc/mounts || grep -q "^$DEVNAME" /etc/mtab); then
+ if [ -x /usr/bin/pumount ] ; then
+ /usr/bin/pumount -l "$DEVNAME";
+ else
+ /bin/umount -l "$DEVNAME";
+ fi
+fi
+
+exit 0
+