summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-14 12:39:51 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-14 12:39:51 +0000
commitcf92f265498a7023d856ae2322c15778208509ef (patch)
tree482e879a6912b583f77effb0c7ea8e101cd6dc39 /sys-apps
parentactually mark hppa stable (diff)
downloadgentoo-2-cf92f265498a7023d856ae2322c15778208509ef.tar.gz
gentoo-2-cf92f265498a7023d856ae2322c15778208509ef.tar.bz2
gentoo-2-cf92f265498a7023d856ae2322c15778208509ef.zip
Version bump #259496 by Raúl Porcel.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/debianutils/ChangeLog8
-rw-r--r--sys-apps/debianutils/debianutils-2.31.ebuild49
-rw-r--r--sys-apps/debianutils/files/debianutils-2.31-no-bs-namespace.patch26
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/debianutils/ChangeLog b/sys-apps/debianutils/ChangeLog
index 390e96d33986..07b4f016c652 100644
--- a/sys-apps/debianutils/ChangeLog
+++ b/sys-apps/debianutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/debianutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.120 2009/03/07 03:27:12 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.121 2009/03/14 12:39:51 vapier Exp $
+
+*debianutils-2.31 (14 Mar 2009)
+
+ 14 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/debianutils-2.31-no-bs-namespace.patch, +debianutils-2.31.ebuild:
+ Version bump #259496 by Raúl Porcel.
07 Mar 2009; Jeremy Olexa <darkside@gentoo.org> debianutils-2.28.5.ebuild:
amd64 stable, bug 260463
diff --git a/sys-apps/debianutils/debianutils-2.31.ebuild b/sys-apps/debianutils/debianutils-2.31.ebuild
new file mode 100644
index 000000000000..0749c9ff7154
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-2.31.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-2.31.ebuild,v 1.1 2009/03/14 12:39:51 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="http://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="kernel_linux static"
+
+PDEPEND="|| ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp sys-freebsd/freebsd-ubin )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.31-no-bs-namespace.patch
+ epatch "${FILESDIR}"/${PN}-2.28.2-mkboot-quiet.patch
+ epatch "${FILESDIR}"/${PN}-2.16.2-palo.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin tempfile run-parts || die
+ if use kernel_linux ; then
+ dosbin installkernel || die "installkernel failed"
+ fi
+
+ into /usr
+ dosbin savelog || die "savelog failed"
+ if use kernel_linux ; then
+ dosbin mkboot || die "mkboot failed"
+ fi
+
+ doman tempfile.1 run-parts.8 savelog.8
+ use kernel_linux && doman installkernel.8 mkboot.8
+ cd debian
+ dodoc changelog control
+}
diff --git a/sys-apps/debianutils/files/debianutils-2.31-no-bs-namespace.patch b/sys-apps/debianutils/files/debianutils-2.31-no-bs-namespace.patch
new file mode 100644
index 000000000000..0e58219228b2
--- /dev/null
+++ b/sys-apps/debianutils/files/debianutils-2.31-no-bs-namespace.patch
@@ -0,0 +1,26 @@
+Allow dots in the names, bug #95173. Patch by Kerin Millar.
+Re-sourced for 2.28.2
+
+--- debianutils-2.28.2/run-parts.8
++++ debianutils-2.28.2/run-parts.8
+@@ -27,7 +27,8 @@
+
+ If neither the \-\-lsbsysinit option nor the \-\-regex option is given
+ then the names must consist entirely of upper and lower case letters,
+-digits, underscores, and hyphens.
++digits, underscores, hyphens, and periods. However, the name must not begin
++with a period.
+
+ If the \-\-lsbsysinit option is given, then the names must not end
+ in .dpkg\-old or .dpkg\-dist or .dpkg\-new or .dpkg\-tmp, and must
+--- debianutils-2.28.2/run-parts.c
++++ debianutils-2.28.2/run-parts.c
+@@ -494,7 +494,7 @@ regex_compile_pattern (void)
+ != 0)
+ pt_regex = &tradre;
+
+- } else if ( (err = regcomp(&classicalre, "^[a-zA-Z0-9_-]+$",
++ } else if ( (err = regcomp(&classicalre, "^[a-zA-Z0-9_-][a-zA-Z0-9._-]+$",
+ REG_EXTENDED | REG_NOSUB)) != 0)
+ pt_regex = &classicalre;
+