summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-10-19 14:20:17 +0000
committerYixun Lan <dlan@gentoo.org>2014-10-19 14:20:17 +0000
commitcf20447f7ba9aeb7ff660c52681550ca52daa4fa (patch)
tree4dbad759e443d1d856630ccf4d4edcbaa9c1f6a1 /sys-apps
parentStable for HPPA (bug #525680). (diff)
downloadgentoo-2-cf20447f7ba9aeb7ff660c52681550ca52daa4fa.tar.gz
gentoo-2-cf20447f7ba9aeb7ff660c52681550ca52daa4fa.tar.bz2
gentoo-2-cf20447f7ba9aeb7ff660c52681550ca52daa4fa.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/tuned/ChangeLog7
-rw-r--r--sys-apps/tuned/tuned-2.4.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-apps/tuned/ChangeLog b/sys-apps/tuned/ChangeLog
index 0dad290b4e4c..f8ff5922c719 100644
--- a/sys-apps/tuned/ChangeLog
+++ b/sys-apps/tuned/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/tuned
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuned/ChangeLog,v 1.1 2014/08/29 04:08:59 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuned/ChangeLog,v 1.2 2014/10/19 14:20:17 dlan Exp $
+
+*tuned-2.4.1 (19 Oct 2014)
+
+ 19 Oct 2014; Yixun Lan <dlan@gentoo.org> +tuned-2.4.1.ebuild:
+ version bump
*tuned-2.3.0 (29 Aug 2014)
diff --git a/sys-apps/tuned/tuned-2.4.1.ebuild b/sys-apps/tuned/tuned-2.4.1.ebuild
new file mode 100644
index 000000000000..d342185dad84
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuned/tuned-2.4.1.ebuild,v 1.1 2014/10/19 14:20:17 dlan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://fedorahosted.org/tuned/"
+SRC_URI="https://fedorahosted.org/releases/t/u/tuned/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sys-power/powertop
+ dev-util/systemtap
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ sed -i \
+ -e "/^UNITDIR = /s:\$(shell rpm --eval '%{_unitdir}'):$(systemd_get_unitdir):" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ Makefile ||die
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/tuned.initd tuned
+
+ python_fix_shebang "${ED}"
+}