summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-01-25 18:59:14 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-01-25 18:59:14 +0000
commitcdbdf5768f979749cd9654c8b0b81e69601f0a5f (patch)
tree5e79a13e87f7fb2a9409ed5ec1a517cff351adae /sys-apps
parentVersion bump; tests are known to fail, but the older version no longer builds... (diff)
downloadgentoo-2-cdbdf5768f979749cd9654c8b0b81e69601f0a5f.tar.gz
gentoo-2-cdbdf5768f979749cd9654c8b0b81e69601f0a5f.tar.bz2
gentoo-2-cdbdf5768f979749cd9654c8b0b81e69601f0a5f.zip
Check that we can actually start up irqbalance based on kernel configuration. Patches and improvements from Kerin Millar <kerframil@gmail.com>
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/irqbalance/ChangeLog9
-rw-r--r--sys-apps/irqbalance/files/irqbalance.init.328
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.5-r1.ebuild (renamed from sys-apps/irqbalance/irqbalance-1.0.5.ebuild)6
3 files changed, 39 insertions, 4 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index 871458a3db9c..0bc0f3e5b2ac 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/irqbalance
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.50 2013/01/25 18:45:25 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.51 2013/01/25 18:59:14 cardoe Exp $
+
+*irqbalance-1.0.5-r1 (25 Jan 2013)
+
+ 25 Jan 2013; Doug Goldstein <cardoe@gentoo.org> -irqbalance-1.0.5.ebuild,
+ +irqbalance-1.0.5-r1.ebuild, +files/irqbalance.init.3:
+ Check that we can actually start up irqbalance based on kernel configuration.
+ Patches and improvements from Kerin Millar <kerframil@gmail.com>
25 Jan 2013; Doug Goldstein <cardoe@gentoo.org> -irqbalance-0.55-r2.ebuild,
-files/irqbalance-0.55-build.patch, -irqbalance-1.0.1.ebuild,
diff --git a/sys-apps/irqbalance/files/irqbalance.init.3 b/sys-apps/irqbalance/files/irqbalance.init.3
new file mode 100644
index 000000000000..551e1c85ea92
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance.init.3
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/files/irqbalance.init.3,v 1.1 2013/01/25 18:59:14 cardoe Exp $
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+command="/usr/sbin/irqbalance"
+command_args="${IRQBALANCE_OPTS}"
+
+check_sysfs() {
+ if grep -q MSI /proc/interrupts 2>/dev/null && \
+ test -z "$(find /sys/devices -type d -name msi_irqs 2>/dev/null)"; then
+ eerror "MSI interrupts found in /proc/interrupts but none found in sysfs."
+ eerror "You need to update your kernel."
+ return 1
+ fi
+}
+
+start() {
+ check_sysfs || return 1
+ ebegin "Starting irqbalance"
+ start-stop-daemon --exec ${command} --start -- ${IRQBALANCE_OPTS}
+ eend $?
+}
diff --git a/sys-apps/irqbalance/irqbalance-1.0.5.ebuild b/sys-apps/irqbalance/irqbalance-1.0.5-r1.ebuild
index 0088b8ee1715..81f955101162 100644
--- a/sys-apps/irqbalance/irqbalance-1.0.5.ebuild
+++ b/sys-apps/irqbalance/irqbalance-1.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.5.ebuild,v 1.2 2013/01/25 18:38:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.5-r1.ebuild,v 1.1 2013/01/25 18:59:14 cardoe Exp $
EAPI=4
@@ -13,7 +13,7 @@ SRC_URI="http://irqbalance.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="caps numa"
+IUSE="caps +numa"
RDEPEND="dev-libs/glib:2
caps? ( sys-libs/libcap-ng )
@@ -34,7 +34,7 @@ src_configure() {
src_install() {
default
- newinitd "${FILESDIR}"/irqbalance.init.2 irqbalance
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
systemd_dounit "${FILESDIR}"/irqbalance.service
}