summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-17 02:44:39 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-17 02:44:39 +0000
commitc8ca2986b7a4048d91c2201070fdea727185a1ee (patch)
treecf361b992323075ea85b36dd1c76496e1c445d23 /sys-apps
parentSplit tcltk USE flag. Bug #17808. (diff)
downloadgentoo-2-c8ca2986b7a4048d91c2201070fdea727185a1ee.tar.gz
gentoo-2-c8ca2986b7a4048d91c2201070fdea727185a1ee.tar.bz2
gentoo-2-c8ca2986b7a4048d91c2201070fdea727185a1ee.zip
Version bump #147541 by Raul Porcel.
(Portage version: 2.1.1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog9
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.2.283
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.3.13
-rw-r--r--sys-apps/findutils/findutils-4.2.28.ebuild65
-rw-r--r--sys-apps/findutils/findutils-4.3.1.ebuild64
5 files changed, 143 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index b458080a6d7b..7a1284d68dc3 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.80 2006/09/09 16:56:26 christel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.81 2006/09/17 02:44:39 vapier Exp $
+
+*findutils-4.3.1 (17 Sep 2006)
+*findutils-4.2.28 (17 Sep 2006)
+
+ 17 Sep 2006; Mike Frysinger <vapier@gentoo.org> +findutils-4.2.28.ebuild,
+ +findutils-4.3.1.ebuild:
+ Version bump #147541 by Raul Porcel.
09 Sep 2006; Christel Dahlskjaer <christel@gentoo.org>
findutils-4.3.0.ebuild:
diff --git a/sys-apps/findutils/files/digest-findutils-4.2.28 b/sys-apps/findutils/files/digest-findutils-4.2.28
new file mode 100644
index 000000000000..071887641327
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.2.28
@@ -0,0 +1,3 @@
+MD5 f5fb3349354ee3d94fceb81dab5c71fd findutils-4.2.28.tar.gz 1089302
+RMD160 3bc4aa5aa9afb4166aef886c9c476f64a5eadffc findutils-4.2.28.tar.gz 1089302
+SHA256 aa27de514b44eb763d276ad8f19fef31a07bd63ac7ca6870d2be5cd58de862c8 findutils-4.2.28.tar.gz 1089302
diff --git a/sys-apps/findutils/files/digest-findutils-4.3.1 b/sys-apps/findutils/files/digest-findutils-4.3.1
new file mode 100644
index 000000000000..6ce1baffc903
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.3.1
@@ -0,0 +1,3 @@
+MD5 1be385bde801d7bc8e02101f96b8a4ee findutils-4.3.1.tar.gz 1191565
+RMD160 aea3de4834ba7ac501a9af38e2ec3e4bc8663656 findutils-4.3.1.tar.gz 1191565
+SHA256 c298b3afa7c5e6a15aa5015454b106461c8079d6a0bba62bc8a8c2057d0c6612 findutils-4.3.1.tar.gz 1191565
diff --git a/sys-apps/findutils/findutils-4.2.28.ebuild b/sys-apps/findutils/findutils-4.2.28.ebuild
new file mode 100644
index 000000000000..fb23be5e262a
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.2.28.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.28.ebuild,v 1.1 2006/09/17 02:44:39 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+SELINUX_PATCH="findutils-4.2.24-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls build selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
+ econf $(use_enable nls) ${myconf} || die "configure failed"
+ emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" libexecdir="${D}/usr/lib/find" install || die
+
+ rm -rf "${D}"/usr/var
+ use build \
+ && rm -rf "${D}"/usr/share \
+ || dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "Please note that the locate and updatedb binaries"
+ ewarn "are now provided by slocate, not findutils."
+}
diff --git a/sys-apps/findutils/findutils-4.3.1.ebuild b/sys-apps/findutils/findutils-4.3.1.ebuild
new file mode 100644
index 000000000000..dd89b65d89e2
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.1.ebuild,v 1.1 2006/09/17 02:44:39 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SELINUX_PATCH="findutils-4.3.0-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if ! has userpriv ${FEATURES} ; then
+ sed -i '/access.exp/d' find/testsuite/Makefile.in
+ rm -f find/testsuite/find.gnu/access.{exp,xo}
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if ([[ ${ELIBC} == "glibc" ]] && has_version '>=sys-libs/glibc-2.3') \
+ || [[ ${ELIBC} == "uclibc" ]]
+ then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}