summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-06 14:20:12 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-06 14:20:12 +0000
commitc3d4828e301252d8a0c1d24651e1d04cfc8eac86 (patch)
treeedc6e1fcad324e375940148b849e10562bb4519c /sys-apps
parentAdd libgnome to RDEPEND, bug #274638. (diff)
downloadgentoo-2-c3d4828e301252d8a0c1d24651e1d04cfc8eac86.tar.gz
gentoo-2-c3d4828e301252d8a0c1d24651e1d04cfc8eac86.tar.bz2
gentoo-2-c3d4828e301252d8a0c1d24651e1d04cfc8eac86.zip
old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/initng/initng-0.6.10.1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/sys-apps/initng/initng-0.6.10.1.ebuild b/sys-apps/initng/initng-0.6.10.1.ebuild
deleted file mode 100644
index 46a59cb9b666..000000000000
--- a/sys-apps/initng/initng-0.6.10.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.6.10.1.ebuild,v 1.2 2007/08/25 17:59:38 vapier Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="A next generation init replacement"
-HOMEPAGE="http://initng.org/"
-SRC_URI="http://download.initng.org/initng/v${PV:0:3}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.1"
-PDEPEND="sys-apps/initng-ifiles"
-
-plugin_warning() {
- if [[ -z ${INITNG_PLUGINS} ]] ; then
- einfo "If you want to customize the list of initng plugins, please"
- einfo "set the INITNG_PLUGINS variable in your make.conf."
- einfo "See http://www.initng.org/wiki/Documents_Plugins for a list of"
- einfo "valid plugins for you to choose from."
- fi
-}
-
-pkg_setup() {
- plugin_warning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's:-Werror::' CMakeLists.txt #136992
-}
-
-src_compile() {
- local x default_opts valid_opts cmake_opts=""
- valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
- default_opts=$(sed -n '/^OPTION(.*ON)$/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
- INITNG_PLUGINS=$(echo ${INITNG_PLUGINS} | tr '[:lower:]' '[:upper:]')
- INITNG_PLUGINS=${INITNG_PLUGINS:-${default_opts}}
- for x in ${valid_opts} ; do
- if hasq ${x} ${INITNG_PLUGINS} || hasq ${x#BUILD_} ${INITNG_PLUGINS} ; then
- cmake_opts="${cmake_opts} -D${x}=ON"
- else
- cmake_opts="${cmake_opts} -D${x}=OFF"
- fi
- done
- cmake \
- -DCMAKE_INSTALL_PREFIX=/ \
- -DLIB_INSTALL_DIR=/$(get_libdir) \
- ${cmake_opts} || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- find "${D}" -name '*.a' -exec rm "{}" \;
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- plugin_warning
- einfo "Remember to add init=/sbin/initng in your grub or lilo config"
- einfo " in order to use initng. Happy testing!"
-}