summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-07-06 10:28:40 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-07-06 10:28:40 +0000
commitbe236bddca4b04e01ac3bf02871c3e51a3ad6d58 (patch)
treec3d31276f8cafdee0f4cf0483516d49e23356365 /sys-apps
parentstable on amd64, bug 230896 (diff)
downloadgentoo-2-be236bddca4b04e01ac3bf02871c3e51a3ad6d58.tar.gz
gentoo-2-be236bddca4b04e01ac3bf02871c3e51a3ad6d58.tar.bz2
gentoo-2-be236bddca4b04e01ac3bf02871c3e51a3ad6d58.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/ChangeLog7
-rw-r--r--sys-apps/mlocate/mlocate-0.21.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index 5d5f63fca7ee..cf53dcef3349 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.21 2008/05/29 10:24:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.22 2008/07/06 10:28:40 opfer Exp $
+
+*mlocate-0.21 (06 Jul 2008)
+
+ 06 Jul 2008; Christian Faulhammer <opfer@gentoo.org> +mlocate-0.21.ebuild:
+ version bump
29 May 2008; Christian Faulhammer <opfer@gentoo.org> -mlocate-0.18.ebuild,
-mlocate-0.19.ebuild:
diff --git a/sys-apps/mlocate/mlocate-0.21.ebuild b/sys-apps/mlocate/mlocate-0.21.ebuild
new file mode 100644
index 000000000000..580d1c5ef490
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.21.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.21.ebuild,v 1.1 2008/07/06 10:28:40 opfer Exp $
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.bz2"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake groupname=locate || die "emake failed"
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
+ fperms 0644 /etc/updatedb.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ chown -R 0:locate "${D}/var/lib/mlocate"
+ fperms 0750 /var/lib/mlocate
+ keepdir /var/lib/mlocate
+}
+
+src_test() {
+ if has userpriv ${FEATURES} && ! has usersandbox ${FEATURES}; then
+ make check-local || die "test suite failed"
+ else
+ ewarn "Activate FEATURES=userpriv and deactivate FEATURES=usersandbox to run testsuite."
+ fi
+}
+
+pkg_postinst() {
+ elog "Note that the /etc/updatedb.conf file is generic"
+ elog "Please customize it to your system requirements"
+}