summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-27 00:46:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-27 00:46:51 +0000
commitbb12ae23d1f3cece4a887d4e8158dd22543a6fb9 (patch)
tree7b8f66d9669af8c8d436c5b2cb3e65240ff60300 /sys-apps
parentbackport quoting fix #156214 (diff)
downloadgentoo-2-bb12ae23d1f3cece4a887d4e8158dd22543a6fb9.tar.gz
gentoo-2-bb12ae23d1f3cece4a887d4e8158dd22543a6fb9.tar.bz2
gentoo-2-bb12ae23d1f3cece4a887d4e8158dd22543a6fb9.zip
Version bump #156268 by Daniel Webert.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lshw/ChangeLog8
-rw-r--r--sys-apps/lshw/files/digest-lshw-02.09b3
-rw-r--r--sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch43
-rw-r--r--sys-apps/lshw/lshw-02.09b.ebuild49
4 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/lshw/ChangeLog b/sys-apps/lshw/ChangeLog
index 2e16ee310357..91c4020dca33 100644
--- a/sys-apps/lshw/ChangeLog
+++ b/sys-apps/lshw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lshw
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/ChangeLog,v 1.36 2006/11/25 18:49:03 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/ChangeLog,v 1.37 2006/11/27 00:46:51 vapier Exp $
+
+*lshw-02.09b (27 Nov 2006)
+
+ 27 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/lshw-02.09b-cpuid-PIC.patch, +lshw-02.09b.ebuild:
+ Version bump #156268 by Daniel Webert.
25 Nov 2006; Bryan Østergaard <kloeri@gentoo.org> lshw-02.06b.ebuild,
lshw-02.08.01b.ebuild:
diff --git a/sys-apps/lshw/files/digest-lshw-02.09b b/sys-apps/lshw/files/digest-lshw-02.09b
new file mode 100644
index 000000000000..8013bea7030c
--- /dev/null
+++ b/sys-apps/lshw/files/digest-lshw-02.09b
@@ -0,0 +1,3 @@
+MD5 2a51cdb0b1a1e6420a1e386a4348d00f lshw-B.02.09.tar.gz 1104639
+RMD160 ebd6dcc1b2c2f0661dcda06b8fe8e8837660d431 lshw-B.02.09.tar.gz 1104639
+SHA256 28006d62cc1376aa3b02048b33a58f6d29ba420fa93909f41aa3d74183532d5c lshw-B.02.09.tar.gz 1104639
diff --git a/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch b/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch
new file mode 100644
index 000000000000..43d2518b2282
--- /dev/null
+++ b/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch
@@ -0,0 +1,43 @@
+The 'cpuid' assembly instruction is notorious for hating PIC.
+
+Here we code two different versions of the cpuid instruction ...
+the first will work when dealing with PIC, while the second is
+slightly faster and can be used with non-PIC.
+
+http://bugs.gentoo.org/61947
+
+--- src/core/cpuid.cc
++++ src/core/cpuid.cc
+@@ -68,9 +68,6 @@
+
+ #ifdef __i386__
+
+-#define cpuid_up(in,a,b,c,d)\
+-asm("cpuid": "=a" (a), "=b" (b), "=c" (c), "=d" (d) : "a" (in));
+-
+ static void cpuid(int cpunumber,
+ unsigned long idx,
+ unsigned long &eax,
+@@ -96,7 +93,21 @@
+ edx = (*(unsigned long *) (buffer + 12));
+ }
+ else
+- cpuid_up(idx, eax, ebx, ecx, edx);
++ asm(
++#ifdef __PIC__
++ "movl %%ebx,%%edi\n"
++ "cpuid\n"
++ "movl %%ebx,%3\n"
++ "movl %%edi,%%ebx\n"
++ : "=a" (eax), "=c" (ecx), "=d" (edx), "=m" (ebx)
++ : "a" (idx)
++ : "edi"
++#else
++ "cpuid\n"
++ : "=a" (eax), "=c" (ecx), "=d" (edx), "=b" (ebx)
++ : "a" (idx)
++#endif
++ );
+ }
+
+ /* Decode Intel TLB and cache info descriptors */
diff --git a/sys-apps/lshw/lshw-02.09b.ebuild b/sys-apps/lshw/lshw-02.09b.ebuild
new file mode 100644
index 000000000000..2205847d2d8e
--- /dev/null
+++ b/sys-apps/lshw/lshw-02.09b.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-02.09b.ebuild,v 1.1 2006/11/27 00:46:51 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+MAJ_PV=${PV:0:${#PV}-1}
+MIN_PVE=${PV:0-1}
+MIN_PV=${MIN_PVE/b/B}
+
+MY_P="$PN-$MIN_PV.$MAJ_PV"
+DESCRIPTION="Hardware Lister"
+HOMEPAGE="http://ezix.org/project/wiki/HardwareLiSter"
+SRC_URI="http://ezix.org/software/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk static"
+
+DEPEND="gtk? ( >=x11-libs/gtk+-2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-02.08.01b-build.patch
+ epatch "${FILESDIR}"/${PN}-02.09b-cpuid-PIC.patch #61947
+}
+
+src_compile() {
+ tc-export CC CXX AR
+ use static && append-ldflags -static
+ emake || die "make failed"
+ if use gtk ; then
+ emake gui || die "make gui failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ if use gtk ; then
+ make DESTDIR="${D}" install-gui || die "install gui failed"
+ fi
+
+ dodoc README docs/*
+}