summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-01 01:47:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-01 01:47:34 +0000
commitadcb68b7b715e9069a378afb19d84e0c0ce9253b (patch)
treed5f7d2c43f75167aa621c4e199f370b192b8c144 /sys-apps
parentInitial import of a split ebuild for USB/PCI ids. (diff)
downloadgentoo-2-adcb68b7b715e9069a378afb19d84e0c0ce9253b.tar.gz
gentoo-2-adcb68b7b715e9069a378afb19d84e0c0ce9253b.tar.bz2
gentoo-2-adcb68b7b715e9069a378afb19d84e0c0ce9253b.zip
Make use of the new hwids ebuild.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pciutils/ChangeLog8
-rw-r--r--sys-apps/pciutils/pciutils-3.1.9-r2.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 945b03255d00..3c4378a57777 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.193 2012/03/25 15:43:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.194 2012/04/01 01:47:34 flameeyes Exp $
+
+*pciutils-3.1.9-r2 (01 Apr 2012)
+
+ 01 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pciutils-3.1.9-r2.ebuild:
+ Make use of the new hwids ebuild.
25 Mar 2012; Markus Meier <maekke@gentoo.org> pciutils-3.1.9-r1.ebuild:
arm stable, bug #407831
diff --git a/sys-apps/pciutils/pciutils-3.1.9-r2.ebuild b/sys-apps/pciutils/pciutils-3.1.9-r2.ebuild
new file mode 100644
index 000000000000..38027c7740f0
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.1.9-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.9-r2.ebuild,v 1.1 2012/04/01 01:47:34 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ sys-apps/hwids"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.7-install-lib.patch #273489
+ epatch "${FILESDIR}"/${PN}-3.1.7-fbsd.patch #262321
+
+ if use static-libs ; then
+ cp -pPR "${S}" "${S}.static" || die
+ fi
+}
+
+pemake() {
+ emake \
+ HOST="${CHOST}" \
+ CROSS_COMPILE="${CHOST}-" \
+ CC="$(tc-getCC)" \
+ DNS="yes" \
+ IDSDIR='$(SHAREDIR)/misc' \
+ MANDIR='$(SHAREDIR)/man' \
+ PREFIX="${EPREFIX}/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(usex zlib) \
+ PCI_COMPRESSED_IDS=0 \
+ PCI_IDS=pci.ids \
+ LIBDIR="\${PREFIX}/$(get_libdir)" \
+ "$@"
+}
+
+src_compile() {
+ pemake OPT="${CFLAGS}" all
+ if use static-libs ; then
+ pemake \
+ -C "${S}.static" \
+ OPT="${CFLAGS}" \
+ SHARED="no" \
+ lib/libpci.a
+ fi
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib
+ use static-libs && dolib.a "${S}.static/lib/libpci.a"
+ dodoc ChangeLog README TODO
+
+ rm "${D}"/usr/bin/update-pciids "${D}"/usr/share/misc/pci.ids \
+ "${D}"/usr/share/man/man8/update-pciids.8*
+
+ newinitd "${FILESDIR}"/init.d-pciparm pciparm
+ newconfd "${FILESDIR}"/conf.d-pciparm pciparm
+}
+
+pkg_postinst() {
+ elog "The 'pcimodules' program has been replaced by 'lspci -k'"
+ elog ""
+ elog "The 'network-cron' USE flag is gone; if you want a more up-to-date"
+ elog "pci.ids file, you should use sys-apps/hwids-99999999 (live ebuild)."
+}