summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-29 18:56:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-29 18:56:35 +0000
commitaaf8b3c068c51921721e836c89bcc5ec042930f3 (patch)
tree0218b15b5ba29ac281bad4aa4172e82a14f578c4 /sys-apps
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-aaf8b3c068c51921721e836c89bcc5ec042930f3.tar.gz
gentoo-2-aaf8b3c068c51921721e836c89bcc5ec042930f3.tar.bz2
gentoo-2-aaf8b3c068c51921721e836c89bcc5ec042930f3.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pciutils/pciutils-3.1.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/sys-apps/pciutils/pciutils-3.1.0.ebuild b/sys-apps/pciutils/pciutils-3.1.0.ebuild
deleted file mode 100644
index 48c9fe01612f..000000000000
--- a/sys-apps/pciutils/pciutils-3.1.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.0.ebuild,v 1.3 2009/01/29 18:25:59 vapier Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="Various utilities dealing with the PCI bus"
-HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
-SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="network-cron zlib"
-
-DEPEND="zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.0.0-build.patch #233314
- epatch "${FILESDIR}"/pcimodules-${PN}-3.1.0.patch
- epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
- cp "${FILESDIR}"/pcimodules.c . || die
- sed -i -e 's:| tr:| LC_ALL=C tr:' lib/configure
- sed -i -e "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
-}
-
-uyesno() { use $1 && echo yes || echo no ; }
-pemake() {
- emake \
- HOST="${CHOST}" \
- CROSS_COMPILE="${CHOST}-" \
- DNS="yes" \
- IDSDIR="/usr/share/misc" \
- MANDIR="/usr/share/man" \
- PREFIX="/usr" \
- SHARED="yes" \
- STRIP="" \
- ZLIB=$(uyesno zlib) \
- "$@"
-}
-
-src_compile() {
- pemake OPT="${CFLAGS}" all pcimodules || die "emake failed"
-}
-
-src_install() {
- pemake DESTDIR="${D}" install install-lib || die
- dosbin pcimodules || die
- doman "${FILESDIR}"/pcimodules.8
- dodoc ChangeLog README TODO
-
- if use network-cron ; then
- exeinto /etc/cron.monthly
- newexe "${FILESDIR}"/pciutils.cron update-pciids \
- || die "Failed to install update cronjob"
- fi
-
- # Install both forms until HAL has migrated
- if use zlib ; then
- local sharedir="${D}/usr/share/misc"
- elog "Providing a backwards compatibility non-compressed pci.ids"
- gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
- fi
-
- newinitd "${FILESDIR}"/init.d-pciparm pciparm
- newconfd "${FILESDIR}"/conf.d-pciparm pciparm
-}