summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:22:51 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:22:51 +0000
commita91842ad21b7f84f9ac036e0776de5531effb3e7 (patch)
tree0d0a85aa3f3f81f88dd08837e2d761da4432cc6f /sys-apps
parentversion bump (diff)
downloadgentoo-2-a91842ad21b7f84f9ac036e0776de5531effb3e7.tar.gz
gentoo-2-a91842ad21b7f84f9ac036e0776de5531effb3e7.tar.bz2
gentoo-2-a91842ad21b7f84f9ac036e0776de5531effb3e7.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/magneto-core/ChangeLog8
-rw-r--r--sys-apps/magneto-core/magneto-core-1.0_rc90.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-apps/magneto-core/ChangeLog b/sys-apps/magneto-core/ChangeLog
index 2e16144c8692..78fe53c1d341 100644
--- a/sys-apps/magneto-core/ChangeLog
+++ b/sys-apps/magneto-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/magneto-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.16 2012/02/12 07:28:08 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.17 2012/03/23 14:22:51 lxnay Exp $
+
+*magneto-core-1.0_rc90 (23 Mar 2012)
+
+ 23 Mar 2012; Fabio Erculiani <lxnay@gentoo.org>
+ +magneto-core-1.0_rc90.ebuild:
+ version bump
*magneto-core-1.0_rc87 (12 Feb 2012)
diff --git a/sys-apps/magneto-core/magneto-core-1.0_rc90.ebuild b/sys-apps/magneto-core/magneto-core-1.0_rc90.ebuild
new file mode 100644
index 000000000000..319a512ae8b2
--- /dev/null
+++ b/sys-apps/magneto-core/magneto-core-1.0_rc90.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/magneto-core-1.0_rc90.ebuild,v 1.1 2012/03/23 14:22:51 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python multilib
+
+DESCRIPTION="Entropy Package Manager notification applet library"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+DEPEND=">=sys-apps/entropy-client-services-${PV}"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-core-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/magneto"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/magneto"
+}