summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-02-11 10:23:47 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-02-11 10:23:47 +0000
commita0261dc917bb52e55b1087b71411ba491c79cbe6 (patch)
tree449123a05201c2d2ea5d0a8504c321082acb0bf3 /sys-apps
parentarm/sh stable #164978 (diff)
downloadgentoo-2-a0261dc917bb52e55b1087b71411ba491c79cbe6.tar.gz
gentoo-2-a0261dc917bb52e55b1087b71411ba491c79cbe6.tar.bz2
gentoo-2-a0261dc917bb52e55b1087b71411ba491c79cbe6.zip
Readd glibc fix to new version
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/suspend2-userui/ChangeLog6
-rw-r--r--sys-apps/suspend2-userui/files/suspend2-userui-0.7.0-syscall.patch25
-rw-r--r--sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild8
3 files changed, 37 insertions, 2 deletions
diff --git a/sys-apps/suspend2-userui/ChangeLog b/sys-apps/suspend2-userui/ChangeLog
index 52aa67ae88ca..d5ef21fa4e55 100644
--- a/sys-apps/suspend2-userui/ChangeLog
+++ b/sys-apps/suspend2-userui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/suspend2-userui
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/ChangeLog,v 1.21 2007/02/09 21:39:16 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/ChangeLog,v 1.22 2007/02/11 10:23:47 alonbl Exp $
+
+ 11 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/suspend2-userui-0.7.0-syscall.patch, suspend2-userui-0.7.0.ebuild:
+ Readd glibc fix to new version
*suspend2-userui-0.7.0 (09 Feb 2007)
diff --git a/sys-apps/suspend2-userui/files/suspend2-userui-0.7.0-syscall.patch b/sys-apps/suspend2-userui/files/suspend2-userui-0.7.0-syscall.patch
new file mode 100644
index 000000000000..9ea0c849b3b1
--- /dev/null
+++ b/sys-apps/suspend2-userui/files/suspend2-userui-0.7.0-syscall.patch
@@ -0,0 +1,25 @@
+diff -urNp suspend2-userui-0.7.0.org/userui.h suspend2-userui-0.7.0/userui.h
+--- suspend2-userui-0.7.0.org/userui.h 2007-01-17 00:16:46.000000000 +0200
++++ suspend2-userui-0.7.0/userui.h 2007-02-11 12:21:22.000000000 +0200
+@@ -1,7 +1,7 @@
+ #ifndef _USERUI_H_
+ #define _USERUI_H_
+
+-#include <linux/unistd.h>
++#include <sys/syscall.h>
+ #include <sys/types.h>
+ #include "suspend_userui.h"
+
+@@ -124,11 +124,6 @@ static __inline__ int generic_fls(int x)
+ /*
+ * Work around random glibc bugs where getpid() caches an invalid pid.
+ */
+-#ifdef _syscall0
+-#define __NR_xgetpid __NR_getpid
+-static inline _syscall0(pid_t, xgetpid);
+-#else
+-static inline pid_t xgetpid(void) { return syscall(__NR_getpid); }
+-#endif
++#define xgetpid() syscall(SYS_getpid)
+
+ #endif /* _USERUI_H_ */
diff --git a/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild b/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild
index 54c1b23a0757..41a94dd701cd 100644
--- a/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild
+++ b/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild,v 1.1 2007/02/09 21:39:16 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/suspend2-userui-0.7.0.ebuild,v 1.2 2007/02/11 10:23:47 alonbl Exp $
inherit toolchain-funcs eutils
@@ -21,6 +21,12 @@ DEPEND="virtual/libc
>=media-libs/libmng-1.0.5
media-libs/libpng )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-syscall.patch"
+}
+
src_compile() {
# allow for static linking for use in initramfs/initrd
use static && LDFLAGS="${LDFLAGS} -static"