summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-21 15:55:11 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-21 15:55:11 +0000
commit9ca476d096c64aff5924f41ec07c9e8aff286a0e (patch)
tree844521b371fc6d58c8480611d0e9122b499cc7f4 /sys-apps
parentStable on alpha, bug #383751 (diff)
downloadgentoo-2-9ca476d096c64aff5924f41ec07c9e8aff286a0e.tar.gz
gentoo-2-9ca476d096c64aff5924f41ec07c9e8aff286a0e.tar.bz2
gentoo-2-9ca476d096c64aff5924f41ec07c9e8aff286a0e.zip
Fix installing pam_systemd.so to /lib*/security. Also, backport a few other fixes.
(Portage version: 2.2.0_alpha84_p38/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog12
-rw-r--r--sys-apps/systemd/systemd-29-r6.ebuild (renamed from sys-apps/systemd/systemd-29-r5.ebuild)12
-rw-r--r--sys-apps/systemd/systemd-37-r4.ebuild (renamed from sys-apps/systemd/systemd-37-r3.ebuild)14
-rw-r--r--sys-apps/systemd/systemd-38-r1.ebuild (renamed from sys-apps/systemd/systemd-38.ebuild)13
4 files changed, 42 insertions, 9 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 1997fe661c8a..d5a6f5c6a04d 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.20 2012/01/14 21:17:23 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.21 2012/01/21 15:55:11 mgorny Exp $
+
+*systemd-38-r1 (21 Jan 2012)
+*systemd-37-r4 (21 Jan 2012)
+*systemd-29-r6 (21 Jan 2012)
+
+ 21 Jan 2012; Michał Górny <mgorny@gentoo.org> -systemd-29-r5.ebuild,
+ +systemd-29-r6.ebuild, -systemd-37-r3.ebuild, +systemd-37-r4.ebuild,
+ -systemd-38.ebuild, +systemd-38-r1.ebuild:
+ Fix installing pam_systemd.so to /lib*/security. Also, backport a few other
+ fixes.
14 Jan 2012; William Hubbs <williamh@gentoo.org> systemd-29-r3.ebuild,
systemd-29-r5.ebuild, systemd-37-r1.ebuild, systemd-37-r3.ebuild,
diff --git a/sys-apps/systemd/systemd-29-r5.ebuild b/sys-apps/systemd/systemd-29-r6.ebuild
index 85b04eb4cdf2..5415105a10b5 100644
--- a/sys-apps/systemd/systemd-29-r5.ebuild
+++ b/sys-apps/systemd/systemd-29-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-29-r5.ebuild,v 1.2 2012/01/14 21:17:23 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-29-r6.ebuild,v 1.1 2012/01/21 15:55:11 mgorny Exp $
EAPI=4
@@ -15,7 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="audit cryptsetup gtk pam plymouth selinux tcpd"
+# We need to depend on sysvinit for sulogin which is used in the rescue
+# mode. Bug #399615.
+
COMMON_DEPEND=">=sys-apps/dbus-1.4.10
+ sys-apps/sysvinit
>=sys-apps/util-linux-2.19
>=sys-fs/udev-171
sys-libs/libcap
@@ -67,7 +71,10 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--with-distro=gentoo
+ # install everything to /usr
--with-rootdir=/usr
+ # but pam modules have to lie in /lib*
+ --with-pamlibdir=/$(get_libdir)/security
--localstatedir=/var
--docdir=/tmp/docs
$(use_enable audit)
@@ -106,6 +113,7 @@ src_install() {
# we just keep sysvinit tools, so no need for the mans
rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
|| die
+ rm "${D}"/usr/share/man/man1/init.1 || die
# Create /run/lock as required by new baselay/OpenRC compat.
insinto /usr/lib/tmpfiles.d
@@ -129,7 +137,7 @@ optfeature() {
}
pkg_postinst() {
- mkdir -p "${ROOT}"/run
+ mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
diff --git a/sys-apps/systemd/systemd-37-r3.ebuild b/sys-apps/systemd/systemd-37-r4.ebuild
index eab43a9781f5..3b1679eed5d9 100644
--- a/sys-apps/systemd/systemd-37-r3.ebuild
+++ b/sys-apps/systemd/systemd-37-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-37-r3.ebuild,v 1.2 2012/01/14 21:17:23 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-37-r4.ebuild,v 1.1 2012/01/21 15:55:11 mgorny Exp $
EAPI=4
@@ -15,7 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="acl audit cryptsetup gtk pam plymouth selinux tcpd"
+# We need to depend on sysvinit for sulogin which is used in the rescue
+# mode. Bug #399615.
+
COMMON_DEPEND=">=sys-apps/dbus-1.4.10
+ sys-apps/sysvinit
>=sys-apps/util-linux-2.19
>=sys-fs/udev-172
sys-libs/libcap
@@ -33,7 +37,7 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.10
tcpd? ( sys-apps/tcp-wrappers )"
# Vala-0.10 doesn't work with libnotify 0.7.1
-VALASLOT="0.12"
+VALASLOT="0.14"
# A little higher than upstream requires
# but I had real trouble with 2.6.37 and systemd.
MINKV="2.6.38"
@@ -70,8 +74,11 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--with-distro=gentoo
+ # install everything to /usr
--with-rootdir=/usr
--with-rootlibdir=/usr/$(get_libdir)
+ # but pam modules have to lie in /lib*
+ --with-pamlibdir=/$(get_libdir)/security
--localstatedir=/var
--docdir=/tmp/docs
$(use_enable acl)
@@ -108,6 +115,7 @@ src_install() {
# we just keep sysvinit tools, so no need for the mans
rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
|| die
+ rm "${D}"/usr/share/man/man1/init.1 || die
# Create /run/lock as required by new baselay/OpenRC compat.
insinto /usr/lib/tmpfiles.d
@@ -131,7 +139,7 @@ optfeature() {
}
pkg_postinst() {
- mkdir -p "${ROOT}"/run
+ mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
diff --git a/sys-apps/systemd/systemd-38.ebuild b/sys-apps/systemd/systemd-38-r1.ebuild
index 271df6d70651..48758ee52aa5 100644
--- a/sys-apps/systemd/systemd-38.ebuild
+++ b/sys-apps/systemd/systemd-38-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-38.ebuild,v 1.2 2012/01/14 21:17:23 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-38-r1.ebuild,v 1.1 2012/01/21 15:55:11 mgorny Exp $
EAPI=4
@@ -15,7 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="acl audit cryptsetup gtk lzma pam plymouth selinux tcpd"
+# We need to depend on sysvinit for sulogin which is used in the rescue
+# mode. Bug #399615.
+
COMMON_DEPEND=">=sys-apps/dbus-1.4.10
+ sys-apps/sysvinit
>=sys-apps/util-linux-2.19
>=sys-fs/udev-172
sys-libs/libcap
@@ -35,7 +39,7 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.10
tcpd? ( sys-apps/tcp-wrappers )"
# Vala-0.10 doesn't work with libnotify 0.7.1
-VALASLOT="0.12"
+VALASLOT="0.14"
# A little higher than upstream requires
# but I had real trouble with 2.6.37 and systemd.
MINKV="2.6.38"
@@ -73,8 +77,11 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--with-distro=gentoo
+ # install everything to /usr
--with-rootprefix=/usr
--with-rootlibdir=/usr/$(get_libdir)
+ # but pam modules have to lie in /lib*
+ --with-pamlibdir=/$(get_libdir)/security
--localstatedir=/var
--docdir=/tmp/docs
$(use_enable acl)
@@ -136,7 +143,7 @@ optfeature() {
}
pkg_postinst() {
- mkdir -p "${ROOT}"/run
+ mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"