summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-21 01:53:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-21 01:53:48 +0000
commit9b313fdc55657cd958f565f7f94a0e106b7d5879 (patch)
tree4d43c687bb1a42a7446a687736709dbde820bf8c /sys-apps
parentBump. Closes #89864 (diff)
downloadgentoo-2-9b313fdc55657cd958f565f7f94a0e106b7d5879.tar.gz
gentoo-2-9b313fdc55657cd958f565f7f94a0e106b7d5879.tar.bz2
gentoo-2-9b313fdc55657cd958f565f7f94a0e106b7d5879.zip
freebsd support #89839
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/sed-4.1.4.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/sed/sed-4.1.4.ebuild b/sys-apps/sed/sed-4.1.4.ebuild
index 41aab52905e0..8c5d4d96ba9c 100644
--- a/sys-apps/sed/sed-4.1.4.ebuild
+++ b/sys-apps/sed/sed-4.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.4.ebuild,v 1.4 2005/04/07 00:21:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.4.ebuild,v 1.5 2005/04/21 01:53:48 vapier Exp $
inherit flag-o-matic
@@ -45,7 +45,9 @@ src_compile() {
src_bootstrap_sed
local myconf=""
- use ppc-macos && myconf="--program-prefix=g"
+ if use ppc-macos || use x86-fbsd ; then
+ myconf="--program-prefix=g"
+ fi
econf \
$(use_enable nls) \
${myconf} \
@@ -69,7 +71,7 @@ src_install() {
fi
rm -f "${D}"/usr/bin/sed
- if use ppc-macos ; then
+ if use ppc-macos || use x86-fbsd ; then
cd "${D}"
local x
for x in $(find . -name 'sed*' -print) ; do