summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-03 14:54:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-03 14:54:11 +0000
commit98369c29035de66ea75bde3009e0c928dd21df97 (patch)
tree2ba74feb862767a82b639d84e1441cbb5cec6a9c /sys-apps
parentversion bump (bug #437042) (diff)
downloadgentoo-2-98369c29035de66ea75bde3009e0c928dd21df97.tar.gz
gentoo-2-98369c29035de66ea75bde3009e0c928dd21df97.tar.bz2
gentoo-2-98369c29035de66ea75bde3009e0c928dd21df97.zip
Version bump.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20121001.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 1df6f8d39aa7..c6a6e3083897 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.25 2012/10/02 12:53:52 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.26 2012/10/03 14:54:11 flameeyes Exp $
+
+*hwids-20121001 (03 Oct 2012)
+
+ 03 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20121001.ebuild:
+ Version bump.
02 Oct 2012; Anthony G. Basile <blueness@gentoo.org> hwids-20120922.ebuild:
stable arm, bug #436186
diff --git a/sys-apps/hwids/hwids-20121001.ebuild b/sys-apps/hwids/hwids-20121001.ebuild
new file mode 100644
index 000000000000..e45da4d1ab06
--- /dev/null
+++ b/sys-apps/hwids/hwids-20121001.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121001.ebuild,v 1.1 2012/10/03 14:54:11 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S="${WORKDIR}"
+
+src_compile() {
+ cd "${S}"/gentoo-hwids-*
+
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+}
+
+src_install() {
+ cd "${S}"/gentoo-hwids-*
+
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+
+ dodoc README.md
+}