summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-08-10 18:05:15 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-08-10 18:05:15 +0000
commit939aa27b8c07740cf4791926775ce845435ef5f7 (patch)
treef148439bde1791576c1275887461c1995560ab03 /sys-apps
parent* bump (diff)
downloadgentoo-2-939aa27b8c07740cf4791926775ce845435ef5f7.tar.gz
gentoo-2-939aa27b8c07740cf4791926775ce845435ef5f7.tar.bz2
gentoo-2-939aa27b8c07740cf4791926775ce845435ef5f7.zip
Backport fix for use with parted-1.7 from current CVS. Bug #134039
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/qtparted/ChangeLog6
-rw-r--r--sys-apps/qtparted/files/qtparted-0.4.5-parted-1.7-fix.patch15
-rw-r--r--sys-apps/qtparted/qtparted-0.4.5.ebuild12
3 files changed, 30 insertions, 3 deletions
diff --git a/sys-apps/qtparted/ChangeLog b/sys-apps/qtparted/ChangeLog
index 4bd2c36b4f48..1af86d5e5100 100644
--- a/sys-apps/qtparted/ChangeLog
+++ b/sys-apps/qtparted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/qtparted
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qtparted/ChangeLog,v 1.25 2006/08/10 10:06:39 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qtparted/ChangeLog,v 1.26 2006/08/10 18:05:14 kevquinn Exp $
+
+ 10 Aug 2006; Kevin F. Quinn <kevquinn@gentoo.org>
+ +files/qtparted-0.4.5-parted-1.7-fix.patch, qtparted-0.4.5.ebuild:
+ Backport fix for use with parted-1.7 from current CVS. Bug #134039
*qtparted-0.4.5 (10 Aug 2006)
diff --git a/sys-apps/qtparted/files/qtparted-0.4.5-parted-1.7-fix.patch b/sys-apps/qtparted/files/qtparted-0.4.5-parted-1.7-fix.patch
new file mode 100644
index 000000000000..cee843b53fc4
--- /dev/null
+++ b/sys-apps/qtparted/files/qtparted-0.4.5-parted-1.7-fix.patch
@@ -0,0 +1,15 @@
+--- src/qp_fswrap.cpp.orig 2006-08-10 18:43:36.000000000 +0200
++++ src/qp_fswrap.cpp 2006-08-10 18:43:58.000000000 +0200
+@@ -1002,7 +1002,11 @@
+ /*---FAT32 WRAPPER---------------------------------------------------------------*/
+ QString QP_FSFat32::_get_label(PedPartition *part)
+ {
+- char buffer[PED_SECTOR_SIZE];
++#ifdef PED_SECTOR_SIZE // PED_SECTOR_SIZE is gone in parted 1.7.x
++ char *buffer=new char[PED_SECTOR_SIZE];
++#else
++ char *buffer=new char[part->disk->dev->sector_size];
++#endif
+ char label[12];
+
+ if (!QP_FSWrap::read_sector(part, 0, 1, buffer))
diff --git a/sys-apps/qtparted/qtparted-0.4.5.ebuild b/sys-apps/qtparted/qtparted-0.4.5.ebuild
index 3d1fdbfa6b5a..500916ff357b 100644
--- a/sys-apps/qtparted/qtparted-0.4.5.ebuild
+++ b/sys-apps/qtparted/qtparted-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qtparted/qtparted-0.4.5.ebuild,v 1.1 2006/08/10 10:06:39 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qtparted/qtparted-0.4.5.ebuild,v 1.2 2006/08/10 18:05:14 kevquinn Exp $
inherit qt3 multilib autotools
@@ -29,6 +29,10 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd ${S}
+
+ # Fix up for parted v1.7
+ epatch ${FILESDIR}/qtparted-0.4.5-parted-1.7-fix.patch
+
# Switch from gksu to kdesu for the KDE desktop.
if use kde; then
use gnome || sed -i -e 's/gksu/kdesu/' debian/menu ||
@@ -36,8 +40,12 @@ src_unpack() {
sed -i -e 's/Exec=/Exec=kdesu /' data/qtparted.desktop ||
die "sed data/qtparted.desktop failed"
fi
+
# Distribution was rigged for unsermake - re-work for normal make,
- # and support autotools 2.6
+ # and support autotools 2.6. Also fix version identifier (this is
+ # a full release, not just cvs).
+ sed -i -e 's:0.4.5-cvs:0.4.5:' configure.ac ||
+ die "sed configure.ac failed for version id"
sed -i -e 's:KDE_AUTOCONF_VERS=\":KDE_AUTOCONF_VERS=\"-2.60 :
s:KDE_AUTOMAKE_VERS=\":KDE_AUTOMAKE_VERS=\"-1.9 :' \
admin/detect-autoconf.sh ||