summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-09 18:36:17 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-09 18:36:17 +0000
commit8b231c59e14a6b746f402500aa65b537cbbd3694 (patch)
tree08316943718640ce2a1ea992b4d6f4b682883f62 /sys-apps
parentFix pcheck warn nonexistant atoms (diff)
downloadgentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.tar.gz
gentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.tar.bz2
gentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.zip
Updated with QA fixes and a gcc 4.6 patch. That was quick...
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dmtcp/ChangeLog6
-rw-r--r--sys-apps/dmtcp/dmtcp-1.2.1.ebuild14
-rw-r--r--sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch21
3 files changed, 36 insertions, 5 deletions
diff --git a/sys-apps/dmtcp/ChangeLog b/sys-apps/dmtcp/ChangeLog
index d8286f74f95e..ea1cecf8c7ea 100644
--- a/sys-apps/dmtcp/ChangeLog
+++ b/sys-apps/dmtcp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dmtcp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/ChangeLog,v 1.1 2011/04/09 17:23:16 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/ChangeLog,v 1.2 2011/04/09 18:36:17 nerdboy Exp $
+
+ 09 Apr 2011; Steve Arnold <nerdboy@gentoo.org> dmtcp-1.2.1.ebuild,
+ +files/dmtcp-1.2.1-gcc46.patch:
+ Updated with QA fixes and a gcc 4.6 patch. That was quick...
*dmtcp-1.2.1 (09 Apr 2011)
diff --git a/sys-apps/dmtcp/dmtcp-1.2.1.ebuild b/sys-apps/dmtcp/dmtcp-1.2.1.ebuild
index 59cba250b40b..272d1b3300a2 100644
--- a/sys-apps/dmtcp/dmtcp-1.2.1.ebuild
+++ b/sys-apps/dmtcp/dmtcp-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/dmtcp-1.2.1.ebuild,v 1.1 2011/04/09 17:23:16 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/dmtcp-1.2.1.ebuild,v 1.2 2011/04/09 18:36:17 nerdboy Exp $
EAPI=3
@@ -16,7 +16,6 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug emacs fast mpi trace"
RDEPEND="sys-libs/readline
- sys-devel/patch
app-arch/gzip
sys-kernel/linux-headers
emacs? ( dev-lisp/clisp )
@@ -26,11 +25,18 @@ RDEPEND="sys-libs/readline
app-shells/tcsh
)"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ sys-devel/patch"
src_prepare() {
+ sed -i -e "s|(cd dmtcp && make install)|\$(MAKE) -C dmtcp install|" \
+ Makefile.in || die "sed make syntax failed"
+ sed -i -e "s/LDFLAGS =/LDFLAGS +=/g" \
+ mtcp/Makefile || die "sed ldflags failed"
+
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+
eautoreconf
- sed -i -e "s|make install|\$(MAKE) install|" Makefile.in
}
src_configure() {
diff --git a/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch b/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch
new file mode 100644
index 000000000000..fd013e3b6ae7
--- /dev/null
+++ b/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch
@@ -0,0 +1,21 @@
+--- a/dmtcp/src/Makefile.am
++++ b/dmtcp/src/Makefile.am
+@@ -66,7 +66,7 @@
+
+ dmtcp_inspector_SOURCES = dmtcp_inspector.cpp
+
+-dmtcphijack_so_LDFLAGS = -shared -avoid-version -module
++dmtcphijack_so_LDFLAGS = -shared -module
+
+ #dmtcp_nocheckpoint_LDFLAGS = -static
+
+--- a/dmtcp/src/dmtcpalloc.h
++++ b/dmtcp/src/dmtcpalloc.h
+@@ -33,6 +33,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <fstream>
++#include <cstddef>
+
+ #define DMTCPSTRING dmtcp::string
+ #define DMTCPVECTOR(T) dmtcp::vector<T>