summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-24 15:39:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-24 15:39:11 +0000
commit894cc3169cc898e7c61162919a5d8d4889a05118 (patch)
treed894ef2fe8d5418d01d9b87f290fc55f157aa36a /sys-apps
parentalso love m68k and hppa (diff)
downloadgentoo-2-894cc3169cc898e7c61162919a5d8d4889a05118.tar.gz
gentoo-2-894cc3169cc898e7c61162919a5d8d4889a05118.tar.bz2
gentoo-2-894cc3169cc898e7c61162919a5d8d4889a05118.zip
fixes to ensure we die on failure of some files. fix paths to migration script
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/hal-0.5.11-r1.ebuild19
-rw-r--r--sys-apps/hal/hal-0.5.11-r4.ebuild16
3 files changed, 28 insertions, 14 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 0c5afaba1a84..446d6c5ee0d7 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.258 2008/12/23 21:04:59 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.259 2008/12/24 15:39:11 cardoe Exp $
+
+ 24 Dec 2008; Doug Goldstein <cardoe@gentoo.org> hal-0.5.11-r1.ebuild,
+ hal-0.5.11-r4.ebuild:
+ fixes to ensure we die on failure of some files. fix paths to migration
+ script
23 Dec 2008; Doug Goldstein <cardoe@gentoo.org> -hal-0.5.7.1-r5.ebuild,
-hal-0.5.9-r1.ebuild, -hal-0.5.9.1-r1.ebuild, -hal-0.5.9.1-r2.ebuild,
diff --git a/sys-apps/hal/hal-0.5.11-r1.ebuild b/sys-apps/hal/hal-0.5.11-r1.ebuild
index 44188364eb25..ad556f421c12 100644
--- a/sys-apps/hal/hal-0.5.11-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.13 2008/12/23 20:43:00 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.14 2008/12/24 15:39:11 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -207,7 +207,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake failed"
dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
# hal umount for unclean unmounts
@@ -225,16 +225,21 @@ src_install() {
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
-i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
- newconfd "${WORKDIR}/0.5.10-hald.conf" hald
+ newconfd "${WORKDIR}/0.5.10-hald.conf" hald || \
+ die "failed to install hald.conf"
if use X ; then
# New Configuration Snippets
- dodoc "${WORKDIR}/${P}-extras/"*.fdi
- dobin "${WORKDIR}/${P}-extras/migrate-xorg-to-fdi.py"
+ dodoc "${WORKDIR}/${P}-config-examples/"*.fdi || \
+ die "dodoc X examples failed"
+ dobin "${WORKDIR}/${P}-config-examples/migrate-xorg-to-fdi.py" || \
+ die "dodoc X migration script failed"
# Automagic conversion!
- elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file..."
- "${WORKDIR}/${P}-extras/migrate-xorg-to-fdi.py" 2> /dev/null > "${D}/etc/hal/fdi/policy/10-x11-input.fdi"
+ elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file"
+ "${WORKDIR}/${P}-config-examples/migrate-xorg-to-fdi.py" 2> /dev/null \
+ > "${D}/etc/hal/fdi/policy/10-x11-input.fdi" || \
+ ewarn "Failed to migrate your keyboard configuration."
fi
# We now create and keep /media here as both gnome-mount and pmount
diff --git a/sys-apps/hal/hal-0.5.11-r4.ebuild b/sys-apps/hal/hal-0.5.11-r4.ebuild
index 6ea0d7693041..97590997382a 100644
--- a/sys-apps/hal/hal-0.5.11-r4.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.4 2008/12/23 20:43:00 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.5 2008/12/24 15:39:11 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -227,16 +227,20 @@ src_install() {
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
-i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
- newconfd "${WORKDIR}/0.5.10-hald.conf" hald
+ newconfd "${WORKDIR}/0.5.10-hald.conf" hald || \
+ die "failed to install hald.conf"
if use X ; then
# New Configuration Snippets
- dodoc "${WORKDIR}/${PN}-config-examples/"*.fdi || die
- dobin "${WORKDIR}/${PN}-config-examples/migrate-xorg-to-fdi.py" || die
+ dodoc "${WORKDIR}/${PN}-config-examples/"*.fdi || \
+ die "dodoc X examples failed"
+ dobin "${WORKDIR}/${PN}-config-examples/migrate-xorg-to-fdi.py" || \
+ die "dodoc X migration script failed"
# Automagic conversion!
- elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file..."
- "${WORKDIR}/${PN}-config-examples/migrate-xorg-to-fdi.py" 2> /dev/null > "${D}/etc/hal/fdi/policy/10-x11-input.fdi" || \
+ elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file"
+ "${WORKDIR}/${PN}-config-examples/migrate-xorg-to-fdi.py" 2> /dev/null \
+ > "${D}/etc/hal/fdi/policy/10-x11-input.fdi" || \
ewarn "Failed to migrate your keyboard configuration."
fi