summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-03 04:12:54 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-03 04:12:54 +0000
commit821ad4c3fac01304460a0fbb175200873dd17c2e (patch)
treec0e4be59130505bca5d8299be323e16c277a55bf /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-821ad4c3fac01304460a0fbb175200873dd17c2e.tar.gz
gentoo-2-821ad4c3fac01304460a0fbb175200873dd17c2e.tar.bz2
gentoo-2-821ad4c3fac01304460a0fbb175200873dd17c2e.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch43
-rw-r--r--sys-apps/lshw/files/lshw-02.12.01b-alignment.patch27
-rw-r--r--sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch298
-rw-r--r--sys-apps/lshw/files/lshw-02.13b-gcc43.patch10
-rw-r--r--sys-apps/lshw/lshw-02.13b.ebuild48
5 files changed, 0 insertions, 426 deletions
diff --git a/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch b/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch
deleted file mode 100644
index 43d2518b2282..000000000000
--- a/sys-apps/lshw/files/lshw-02.09b-cpuid-PIC.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-The 'cpuid' assembly instruction is notorious for hating PIC.
-
-Here we code two different versions of the cpuid instruction ...
-the first will work when dealing with PIC, while the second is
-slightly faster and can be used with non-PIC.
-
-http://bugs.gentoo.org/61947
-
---- src/core/cpuid.cc
-+++ src/core/cpuid.cc
-@@ -68,9 +68,6 @@
-
- #ifdef __i386__
-
--#define cpuid_up(in,a,b,c,d)\
--asm("cpuid": "=a" (a), "=b" (b), "=c" (c), "=d" (d) : "a" (in));
--
- static void cpuid(int cpunumber,
- unsigned long idx,
- unsigned long &eax,
-@@ -96,7 +93,21 @@
- edx = (*(unsigned long *) (buffer + 12));
- }
- else
-- cpuid_up(idx, eax, ebx, ecx, edx);
-+ asm(
-+#ifdef __PIC__
-+ "movl %%ebx,%%edi\n"
-+ "cpuid\n"
-+ "movl %%ebx,%3\n"
-+ "movl %%edi,%%ebx\n"
-+ : "=a" (eax), "=c" (ecx), "=d" (edx), "=m" (ebx)
-+ : "a" (idx)
-+ : "edi"
-+#else
-+ "cpuid\n"
-+ : "=a" (eax), "=c" (ecx), "=d" (edx), "=b" (ebx)
-+ : "a" (idx)
-+#endif
-+ );
- }
-
- /* Decode Intel TLB and cache info descriptors */
diff --git a/sys-apps/lshw/files/lshw-02.12.01b-alignment.patch b/sys-apps/lshw/files/lshw-02.12.01b-alignment.patch
deleted file mode 100644
index c1dbae83810a..000000000000
--- a/sys-apps/lshw/files/lshw-02.12.01b-alignment.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-fix from upstream for alignment errors
-
-http://ezix.org/project/changeset?new=packages/lshw/development/src/core/scsi.cc%401927&old=packages/lshw/development/src/core/scsi.cc%401923
-
---- src/core/scsi.cc
-+++ src/core/scsi.cc
-@@ -566,11 +566,15 @@
- if (fd >= 0)
- {
- int bus = -1;
-- char host[50];
-- int * length = (int*)host;
-- *length = sizeof(host);
-- memset(host, 0, sizeof(host));
-- if (ioctl(fd, SCSI_IOCTL_PROBE_HOST, &host) >= 0)
-+ union
-+ {
-+ char host[50];
-+ int length;
-+ } tmp;
-+ tmp.length = sizeof(tmp.host);
-+ memset(tmp.host, 0, sizeof(tmp.host));
-+
-+ if(ioctl(fd, SCSI_IOCTL_PROBE_HOST, &tmp.length) >= 0)
- {
- if (ioctl(fd, SCSI_IOCTL_GET_BUS_NUMBER, &bus) >= 0)
- {
diff --git a/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch b/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch
deleted file mode 100644
index f8612009f7c9..000000000000
--- a/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch
+++ /dev/null
@@ -1,298 +0,0 @@
-fix from upstream for building with gcc-4.3
-
-http://bugs.gentoo.org/213912
-
---- lshw-B.02.12.01/src/core/blockio.cc
-+++ lshw-B.02.12.01/src/core/blockio.cc
-@@ -11,6 +11,7 @@
- #include "blockio.h"
- #include "osutils.h"
- #include <stdio.h>
-+#include <string.h>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
---- lshw-B.02.12.01/src/core/cdrom.cc
-+++ lshw-B.02.12.01/src/core/cdrom.cc
-@@ -23,6 +23,7 @@
- #include <sys/ioctl.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <limits.h>
- #include <linux/cdrom.h>
-
- __ID("@(#) $Id: cdrom.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/cpuid.cc
-+++ lshw-B.02.12.01/src/core/cpuid.cc
-@@ -1,6 +1,7 @@
- #include "version.h"
- #include "cpuid.h"
- #include <stdio.h>
-+#include <string.h>
- #include <unistd.h>
- #include <fcntl.h>
- #include <sys/stat.h>
---- lshw-B.02.12.01/src/core/cpuinfo.cc
-+++ lshw-B.02.12.01/src/core/cpuinfo.cc
-@@ -6,6 +6,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include <vector>
-
- __ID("@(#) $Id: cpuinfo.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/device-tree.cc
-+++ lshw-B.02.12.01/src/core/device-tree.cc
-@@ -15,7 +15,9 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #include <unistd.h>
- #include <dirent.h>
-
---- lshw-B.02.12.01/src/core/fb.cc
-+++ lshw-B.02.12.01/src/core/fb.cc
-@@ -12,6 +12,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
- #include <errno.h>
-
- __ID("@(#) $Id: fb.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/hw.cc
-+++ lshw-B.02.12.01/src/core/hw.cc
-@@ -4,12 +4,14 @@
- #include "version.h"
- #include "options.h"
- #include "heuristics.h"
-+#include <cstring>
- #include <vector>
- #include <map>
- #include <sstream>
- #include <unistd.h>
- #include <stdio.h>
- #include <ctype.h>
-+#include <limits.h>
- #include <unistd.h>
- #include <sys/utsname.h>
-
---- lshw-B.02.12.01/src/core/ide.cc
-+++ lshw-B.02.12.01/src/core/ide.cc
-@@ -23,6 +23,8 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
- #include <dirent.h>
- #include <ctype.h>
- #include <vector>
---- lshw-B.02.12.01/src/core/ideraid.cc
-+++ lshw-B.02.12.01/src/core/ideraid.cc
-@@ -17,6 +17,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
- #include <dirent.h>
- #include <ctype.h>
- #include <vector>
---- lshw-B.02.12.01/src/core/lvm.cc
-+++ lshw-B.02.12.01/src/core/lvm.cc
-@@ -12,6 +12,7 @@
- #include "version.h"
- #include "lvm.h"
- #include "osutils.h"
-+#include <string.h>
-
- __ID("@(#) $Id: lvm.cc 1907 2007-10-13 22:23:16Z lyonel $");
-
---- lshw-B.02.12.01/src/core/mounts.cc
-+++ lshw-B.02.12.01/src/core/mounts.cc
-@@ -11,6 +11,8 @@
- #include <iostream>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <unistd.h>
-
-
---- lshw-B.02.12.01/src/core/osutils.cc
-+++ lshw-B.02.12.01/src/core/osutils.cc
-@@ -9,6 +9,7 @@
- #include <dirent.h>
- #include <limits.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <regex.h>
- #include <ctype.h>
- #include <stdio.h>
---- lshw-B.02.12.01/src/core/parisc.cc
-+++ lshw-B.02.12.01/src/core/parisc.cc
-@@ -17,6 +17,8 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <unistd.h>
- #include <dirent.h>
-
---- lshw-B.02.12.01/src/core/partitions.cc
-+++ lshw-B.02.12.01/src/core/partitions.cc
-@@ -24,6 +24,8 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <string.h>
-+#include <stdlib.h>
- #include <unistd.h>
- #include <stdint.h>
-
---- lshw-B.02.12.01/src/core/pci.cc
-+++ lshw-B.02.12.01/src/core/pci.cc
-@@ -6,6 +6,8 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
- #include <dirent.h>
-
- __ID("@(#) $Id: pci.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/pcmcia.cc
-+++ lshw-B.02.12.01/src/core/pcmcia.cc
-@@ -7,6 +7,8 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <errno.h>
- #include <dirent.h>
-
---- lshw-B.02.12.01/src/core/pcmcia-legacy.cc
-+++ lshw-B.02.12.01/src/core/pcmcia-legacy.cc
-@@ -7,6 +7,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
- #include <errno.h>
-
- __ID("@(#) $Id: pcmcia-legacy.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/pnp.cc
-+++ lshw-B.02.12.01/src/core/pnp.cc
-@@ -9,6 +9,7 @@
- #include "version.h"
- #include "pnp.h"
-
-+#include <stdlib.h>
- #include <string.h>
-
- __ID("@(#) $Id: pnp.cc 1907 2007-10-13 22:23:16Z lyonel $");
---- lshw-B.02.12.01/src/core/print.cc
-+++ lshw-B.02.12.01/src/core/print.cc
-@@ -11,10 +11,12 @@
- #include "options.h"
- #include "version.h"
- #include "osutils.h"
-+#include <cstring>
- #include <iostream>
- #include <sstream>
- #include <iomanip>
- #include <unistd.h>
-+#include <stdlib.h>
- #include <stdio.h>
- #include <sys/ioctl.h>
- #include <termios.h>
---- lshw-B.02.12.01/src/core/scsi.cc
-+++ lshw-B.02.12.01/src/core/scsi.cc
-@@ -12,6 +12,8 @@
- #include <unistd.h>
- #include <dirent.h>
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <scsi/sg.h>
- #include <scsi/scsi.h>
- #ifndef MKDEV
---- lshw-B.02.12.01/src/core/smp.cc
-+++ lshw-B.02.12.01/src/core/smp.cc
-@@ -9,6 +9,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <string.h>
- #include <unistd.h>
-
- #include "osutils.h"
---- lshw-B.02.12.01/src/core/spd.cc
-+++ lshw-B.02.12.01/src/core/spd.cc
-@@ -5,6 +5,7 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <string.h>
- #include <string>
- #include <dirent.h>
- #include <stdio.h>
---- lshw-B.02.12.01/src/core/sysfs.cc
-+++ lshw-B.02.12.01/src/core/sysfs.cc
-@@ -11,6 +11,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #include <dirent.h>
- #include <libgen.h>
- #include <sys/stat.h>
---- lshw-B.02.12.01/src/core/usb.cc
-+++ lshw-B.02.12.01/src/core/usb.cc
-@@ -18,6 +18,8 @@
- #include <sys/ioctl.h>
- #include <errno.h>
- #include <fcntl.h>
-+#include <string.h>
-+#include <stdlib.h>
- #include <unistd.h>
- #include <dirent.h>
-
---- lshw-B.02.12.01/src/core/volumes.cc
-+++ lshw-B.02.12.01/src/core/volumes.cc
-@@ -15,6 +15,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <string.h>
- #include <unistd.h>
- #include <stdint.h>
- #include <time.h>
---- lshw-B.02.12.01/src/gui/engine.cc
-+++ lshw-B.02.12.01/src/gui/engine.cc
-@@ -9,6 +9,8 @@
- #include <iostream>
- #include <fstream>
- #include <sys/utsname.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <libgen.h>
-
- static char *id = "@(#) $Id: engine.cc 1907 2007-10-13 22:23:16Z lyonel $";
---- lshw-B.02.12.01/src/lshw.cc
-+++ lshw-B.02.12.01/src/lshw.cc
-@@ -8,6 +8,8 @@
-
- #include <unistd.h>
- #include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
- #include <iostream>
-
- __ID("@(#) $Id: lshw.cc 1907 2007-10-13 22:23:16Z lyonel $");
diff --git a/sys-apps/lshw/files/lshw-02.13b-gcc43.patch b/sys-apps/lshw/files/lshw-02.13b-gcc43.patch
deleted file mode 100644
index d3b8012542c4..000000000000
--- a/sys-apps/lshw/files/lshw-02.13b-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/core/abi.cc
-+++ src/core/abi.cc
-@@ -9,6 +9,7 @@
- #include "osutils.h"
- #include <unistd.h>
- #include <dirent.h>
-+#include <stdlib.h>
-
- __ID("@(#) $Id: lshw-02.13b-gcc43.patch,v 1.1 2008/05/31 10:13:09 vapier Exp $");
-
diff --git a/sys-apps/lshw/lshw-02.13b.ebuild b/sys-apps/lshw/lshw-02.13b.ebuild
deleted file mode 100644
index e5794ccfb2bf..000000000000
--- a/sys-apps/lshw/lshw-02.13b.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-02.13b.ebuild,v 1.6 2008/10/14 20:00:38 ranger Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-MAJ_PV=${PV:0:${#PV}-1}
-MIN_PVE=${PV:0-1}
-MIN_PV=${MIN_PVE/b/B}
-
-MY_P="$PN-$MIN_PV.$MAJ_PV"
-DESCRIPTION="Hardware Lister"
-HOMEPAGE="http://ezix.org/project/wiki/HardwareLiSter"
-SRC_URI="http://ezix.org/software/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="gtk static"
-
-DEPEND="gtk? ( >=x11-libs/gtk+-2 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-02.12.01b-build.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- tc-export CC CXX AR
- use static && append-ldflags -static
- emake || die "make failed"
- if use gtk ; then
- emake gui || die "make gui failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README docs/*
- if use gtk ; then
- emake DESTDIR="${D}" install-gui || die "install gui failed"
- make_desktop_entry /usr/sbin/gtk-lshw "Hardware Lister" "/usr/share/lshw/artwork/logo.svg"
- fi
-}