summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-15 12:26:09 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-15 12:26:09 +0000
commit770733cdfdaee6e0b23b696b19e97baaed636526 (patch)
treea957c6959355fe267e207f4b0551d31abba65e00 /sys-apps
parentAdd missing keywords, ebuild does not install any binaries (diff)
downloadgentoo-2-770733cdfdaee6e0b23b696b19e97baaed636526.tar.gz
gentoo-2-770733cdfdaee6e0b23b696b19e97baaed636526.tar.bz2
gentoo-2-770733cdfdaee6e0b23b696b19e97baaed636526.zip
Bump to 3.0.2, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gnome-disk-utility/ChangeLog9
-rw-r--r--sys-apps/gnome-disk-utility/files/gnome-disk-utility-2.91.6-optional-avahi.patch75
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-3.0.2.ebuild71
3 files changed, 154 insertions, 1 deletions
diff --git a/sys-apps/gnome-disk-utility/ChangeLog b/sys-apps/gnome-disk-utility/ChangeLog
index 4889f015fd7a..d823459053de 100644
--- a/sys-apps/gnome-disk-utility/ChangeLog
+++ b/sys-apps/gnome-disk-utility/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/gnome-disk-utility
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gnome-disk-utility/ChangeLog,v 1.52 2011/08/13 18:23:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gnome-disk-utility/ChangeLog,v 1.53 2011/08/15 12:26:09 nirbheek Exp $
+
+*gnome-disk-utility-3.0.2 (15 Aug 2011)
+
+ 15 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/gnome-disk-utility-2.91.6-optional-avahi.patch,
+ +gnome-disk-utility-3.0.2.ebuild:
+ Bump to 3.0.2, from gnome overlay for GNOME 3
13 Aug 2011; Raúl Porcel <armin76@gentoo.org>
gnome-disk-utility-2.32.1-r1.ebuild:
diff --git a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-2.91.6-optional-avahi.patch b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-2.91.6-optional-avahi.patch
new file mode 100644
index 000000000000..b9080ea06ae0
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-2.91.6-optional-avahi.patch
@@ -0,0 +1,75 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,7 +150,26 @@ PKG_CHECK_MODULES(LIBNOTIFY, [libnotify >= $LIBNOTIFY_REQUIRED])
+ PKG_CHECK_MODULES(UDISKS, [udisks >= $UDISKS_REQUIRED udisks < $UDISKS_NEXT_ABI_INCOMPATIBLE_VERSION])
+ PKG_CHECK_MODULES(X11, [x11])
+ PKG_CHECK_MODULES(LIBATASMART, [libatasmart >= 0.14])
+-PKG_CHECK_MODULES(AVAHI_UI, [avahi-ui-gtk3 >= $AVAHI_UI_REQUIRED])
++
++# *************
++# Avahi
++# *************
++
++have_avahi_ui=no
++AC_ARG_ENABLE(avahi-ui, AS_HELP_STRING([--disable-avahi-ui], [disable use of Avahi for server searching]))
++
++if test "x$enable_avahi_ui" != "xno"; then
++ PKG_CHECK_MODULES(AVAHI_UI, avahi-ui-gtk3 >= $AVAHI_UI_REQUIRED,
++ [AC_DEFINE(HAVE_AVAHI_UI, 1, [Define if avahi-ui-gtk3 is available])
++ have_avahi_ui=yes], have_avahi_ui=no)
++ if test "x$have_avahi_ui" = xno -a "x$enable_avahi_ui" = xyes; then
++ AC_MSG_ERROR([avahi-ui-gtk3 support requested but libraries not found])
++ fi
++fi
++
++AC_SUBST(AVAHI_UI_LIBS)
++AC_SUBST(AVAHI_UI_CFLAGS)
++AM_CONDITIONAL(ENABLE_AVAHI_UI, [test "$have_avahi_ui" = "yes"])
+
+ # *************
+ # Remote Access
+--- a/src/gdu-gtk/gdu-connect-to-server-dialog.c
++++ b/src/gdu-gtk/gdu-connect-to-server-dialog.c
+@@ -24,7 +24,10 @@
+
+ #include "config.h"
+ #include <glib/gi18n-lib.h>
++
++#ifdef HAVE_AVAHI_UI
+ #include <avahi-ui/avahi-ui.h>
++#endif
+
+ #include "gdu-connect-to-server-dialog.h"
+
+@@ -143,6 +146,7 @@ gdu_connect_to_server_dialog_get_address (GduConnectToServerDialog *dialog)
+
+ /* ---------------------------------------------------------------------------------------------------- */
+
++#ifdef HAVE_AVAHI_UI
+ static void
+ on_dns_sd_clicked (GtkButton *button,
+ gpointer user_data)
+@@ -171,6 +175,7 @@ on_dns_sd_clicked (GtkButton *button,
+
+ gtk_widget_destroy (service_dialog);
+ }
++#endif
+
+ /* ---------------------------------------------------------------------------------------------------- */
+
+@@ -218,6 +223,7 @@ gdu_connect_to_server_dialog_constructed (GObject *object)
+ GTK_STOCK_CONNECT,
+ GTK_RESPONSE_OK);
+
++#ifdef HAVE_AVAHI_UI
+ button = gtk_button_new_with_mnemonic (_("_Browse..."));
+ image = gtk_image_new_from_stock (GTK_STOCK_NETWORK, GTK_ICON_SIZE_BUTTON);
+ gtk_button_set_image (GTK_BUTTON (button), image);
+@@ -235,6 +241,7 @@ gdu_connect_to_server_dialog_constructed (GObject *object)
+ "clicked",
+ G_CALLBACK (on_dns_sd_clicked),
+ dialog);
++#endif
+
+ content_area = gtk_dialog_get_content_area (GTK_DIALOG (dialog));
+
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.0.2.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.0.2.ebuild
new file mode 100644
index 000000000000..c4c81f211f4f
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.0.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gnome-disk-utility/gnome-disk-utility-3.0.2.ebuild,v 1.1 2011/08/15 12:26:09 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Disk Utility for GNOME using devicekit-disks"
+HOMEPAGE="http://git.gnome.org/browse/gnome-disk-utility"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="avahi doc fat gnome-keyring nautilus remote-access"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+CDEPEND="
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/libunique-2.90.1:3
+ >=x11-libs/gtk+-2.90.7:3
+ =sys-fs/udisks-1.0*[remote-access?]
+ >=dev-libs/libatasmart-0.14
+ >=x11-libs/libnotify-0.6.1
+
+ avahi? ( >=net-dns/avahi-0.6.25[gtk3] )
+ gnome-keyring? ( || (
+ gnome-base/libgnome-keyring
+ <gnome-base/gnome-keyring-2.29.4 ) )
+ nautilus? ( >=gnome-base/nautilus-2.91.0 )
+"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils
+ fat? ( sys-fs/dosfstools )
+ !!sys-apps/udisks"
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+ gnome-base/gnome-common
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable avahi avahi-ui)
+ $(use_enable nautilus)
+ $(use_enable remote-access)
+ $(use_enable gnome-keyring)"
+ DOCS="AUTHORS NEWS README TODO"
+}
+
+src_prepare() {
+ sed -e '/printf/s:nautilus:xdg-open:' \
+ -i src/palimpsest/gdu-section-volumes.c || die "#350919"
+
+ # Keep avahi optional, upstream bug #631986
+ epatch "${FILESDIR}/${PN}-2.91.6-optional-avahi.patch"
+ intltoolize --force --copy --automake || die
+ eautoreconf
+
+ gnome2_src_prepare
+}