summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-05 21:28:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-05 21:28:53 +0000
commit724eff56df7f4474e447181de681161938f7bc1c (patch)
tree9bcd0a7eb812d957a06973a096bc3e8910695fd5 /sys-apps
parent~amd64 (diff)
downloadgentoo-2-724eff56df7f4474e447181de681161938f7bc1c.tar.gz
gentoo-2-724eff56df7f4474e447181de681161938f7bc1c.tar.bz2
gentoo-2-724eff56df7f4474e447181de681161938f7bc1c.zip
tweak how strip-linguas is used #104882
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/man-1.6a.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/man/man-1.6a.ebuild b/sys-apps/man/man-1.6a.ebuild
index bf5eb6c5fb45..56409cd10c9c 100644
--- a/sys-apps/man/man-1.6a.ebuild
+++ b/sys-apps/man/man-1.6a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6a.ebuild,v 1.3 2005/09/03 22:20:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6a.ebuild,v 1.4 2005/09/05 21:28:53 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -50,6 +50,8 @@ src_unpack() {
-e "/^LDFLAGS = -s/s:=.*:=${LDFLAGS}:" \
src/Makefile.in \
|| die "failed to edit default LDLFAGS"
+
+ strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
}
src_compile() {
@@ -57,7 +59,6 @@ src_compile() {
local myconf=
if use nls ; then
- strip-linguas $(cd man; echo ??)
if [[ -z ${LINGUAS} ]] ; then
myconf="+lang all"
else