summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-08-26 10:39:47 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-08-26 10:39:47 +0000
commit6ed65484c1b942904218101ad8a503fe7ebf5238 (patch)
treec2213d1fdbc997b0c37ec939648efe88569c188f /sys-apps
parentFix issues with gcc-2.95.3, bug #27329, thanks to (diff)
downloadgentoo-2-6ed65484c1b942904218101ad8a503fe7ebf5238.tar.gz
gentoo-2-6ed65484c1b942904218101ad8a503fe7ebf5238.tar.bz2
gentoo-2-6ed65484c1b942904218101ad8a503fe7ebf5238.zip
Fix issues with gcc-2.95.3, bug #27329, thanks to
patch from TGL <degrenier@easyconnect.fr>.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog9
-rw-r--r--sys-apps/coreutils/Manifest9
-rw-r--r--sys-apps/coreutils/coreutils-5.0-r3.ebuild106
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.0-r33
4 files changed, 122 insertions, 5 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 199bee5ec137..247e890f6970 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.24 2003/08/26 04:22:51 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.25 2003/08/26 10:39:04 azarah Exp $
+
+*coreutils-5.0-r3 (26 Aug 2003)
+
+ 26 Aug 2003; Martin Schlemmer <azarah@gentoo.org> Manifest,
+ coreutils-5.0-r3.ebuild:
+ Fix issues with gcc-2.95.3, bug #27329, thanks to patch from TGL
+ <degrenier@easyconnect.fr>.
25 Aug 2003; Chris PeBenito <pebenito@gentoo.org> coreutils-5.0-r2.ebuild:
Fix selinux patch, as the old patch fails to apply when the progress bar patch
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 35d78e6d5e2a..7155810d83c7 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,8 +1,9 @@
-MD5 9afbb4a9afd5f772f84414230da89250 ChangeLog 4071
+MD5 db77997abb943de25db93944a432c07a ChangeLog 4289
MD5 3ba942f3d52e41ae12fc683369efaf04 coreutils-4.5.11-r1.ebuild 2512
-MD5 75e6eb1a0ab13ae89ba6d12c7614def8 coreutils-5.0-r2.ebuild 2768
+MD5 c39eabc6d9731ca0e265d45f3f25bd5b coreutils-5.0-r2.ebuild 2768
+MD5 09fb62128419ce342928ba3a28139d6d coreutils-5.0-r3.ebuild 2766
MD5 eb76aec2f84f8c181e613968475c3a5e coreutils-5.0-r1.ebuild 2731
-MD5 b48c212497b241726481070b8eefe6de .coreutils-5.0-r2.ebuild.swp 12288
-MD5 174f99d91c509210fda44c172686864d files/digest-coreutils-5.0-r2 216
+MD5 4f881af0d43d43da188e159999bc5f56 files/digest-coreutils-5.0-r2 216
MD5 0ff5f66b1d04c85d2434fa73547e67f3 files/digest-coreutils-4.5.11-r1 207
MD5 d0d4edd45d2bebd31947fec9818be33e files/digest-coreutils-5.0-r1 213
+MD5 174f99d91c509210fda44c172686864d files/digest-coreutils-5.0-r3 216
diff --git a/sys-apps/coreutils/coreutils-5.0-r3.ebuild b/sys-apps/coreutils/coreutils-5.0-r3.ebuild
new file mode 100644
index 000000000000..bc6872af4378
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.0-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r3.ebuild,v 1.1 2003/08/26 10:39:04 azarah Exp $
+
+inherit eutils
+
+IUSE="nls build selinux"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="http://ftp.gnu.org/pub/gnu/coreutils/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo-1.4.tar.bz2
+ selinux? mirror://gentoo/${P}-r2-selinux.patch.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc alpha ~hppa ~arm ~mips"
+
+DEPEND=">=sys-apps/portage-2.0.48-r3
+ virtual/glibc
+ nls? ( sys-devel/gettext )
+ selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
+
+# the sandbox code in portage-2.0.48 causes breakage
+export SANDBOX_DISABLED="1"
+
+PATCHDIR=${WORKDIR}/${PN}-gentoo-patches
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${PATCHDIR}/${PN}-progress-bar.patch
+
+ use selinux && epatch ${DISTDIR}/${P}-r2-selinux.patch.bz2
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ epatch ${PATCHDIR}/${PN}-gentoo-rms.patch
+
+ # do not include su infopage, as it is not valid for the su
+ # from sys-apps/shadow that we are using.
+ epatch ${PATCHDIR}/${PN}-remove-su-info.patch
+
+ # Patch to add processor specific info to the uname output
+ if [ -z "`use hppa`" ] && [ -z "`use arm`" ]
+ then
+ epatch ${PATCHDIR}/${PN}-gentoo-uname.patch
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/{bin,usr/bin}/hostname ${D}/usr/share/man/man1/hostname.*
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/{bin,usr/bin}/su ${D}/usr/share/man/man1/su.*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/{bin,usr/bin}/uptime ${D}/usr/share/man/man1/uptime*
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0-r3 b/sys-apps/coreutils/files/digest-coreutils-5.0-r3
new file mode 100644
index 000000000000..8d03e4909dd9
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.0-r3
@@ -0,0 +1,3 @@
+MD5 94e5558ee2a65723d4840bfde2d323f0 coreutils-5.0.tar.bz2 3952653
+MD5 f21f22359ace9cdae063912f5d1b500c coreutils-gentoo-1.4.tar.bz2 8170
+MD5 56309285e57c7175a993c20a2084c0e3 coreutils-5.0-r2-selinux.patch.bz2 20091