summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-26 19:35:47 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-26 19:35:47 +0000
commit6dc4201ab63893c21f7fede9b4a6c2ec309e0a8b (patch)
treefc917e3097dd21b055a2c6ee43dd357e6c04c889 /sys-apps
parentalpha/ia64/sh/sparc stable wrt #419473 (diff)
downloadgentoo-2-6dc4201ab63893c21f7fede9b4a6c2ec309e0a8b.tar.gz
gentoo-2-6dc4201ab63893c21f7fede9b4a6c2ec309e0a8b.tar.bz2
gentoo-2-6dc4201ab63893c21f7fede9b4a6c2ec309e0a8b.zip
Version bump.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwinfo/ChangeLog7
-rw-r--r--sys-apps/hwinfo/hwinfo-20.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/hwinfo/ChangeLog b/sys-apps/hwinfo/ChangeLog
index ad0e84724017..8dc03e1efa43 100644
--- a/sys-apps/hwinfo/ChangeLog
+++ b/sys-apps/hwinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.29 2012/08/24 07:17:05 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.30 2012/08/26 19:35:47 radhermit Exp $
+
+*hwinfo-20.0 (26 Aug 2012)
+
+ 26 Aug 2012; Tim Harder <radhermit@gentoo.org> +hwinfo-20.0.ebuild:
+ Version bump.
24 Aug 2012; Michael Weber <xmw@gentoo.org> hwinfo-19.1.ebuild:
ppc stable (bug 422173).
diff --git a/sys-apps/hwinfo/hwinfo-20.0.ebuild b/sys-apps/hwinfo/hwinfo-20.0.ebuild
new file mode 100644
index 000000000000..c2c3a702a673
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-20.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/hwinfo-20.0.ebuild,v 1.1 2012/08/26 19:35:47 radhermit Exp $
+
+EAPI=4
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="hwinfo is the hardware detection tool used in SuSE Linux."
+HOMEPAGE="http://www.opensuse.org/"
+SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-1.4.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Avoid -I directories for dbus because HAL is obsolete.
+ sed -i -e '/CFLAGS/d' src/hd/Makefile || die
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) -shared:& $(LDFLAGS):' src/Makefile || die
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+
+ dodoc changelog README
+ doman doc/hwinfo.8
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/example*.c
+}