summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-28 14:03:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-28 14:03:09 +0000
commit6c9aea63612f34757145f1fc45bdbd6431e222e9 (patch)
tree7473654b1090cc1d17f054ce206b2cc93dcfd83b /sys-apps
parentSign Manfiest (diff)
downloadgentoo-2-6c9aea63612f34757145f1fc45bdbd6431e222e9.tar.gz
gentoo-2-6c9aea63612f34757145f1fc45bdbd6431e222e9.tar.bz2
gentoo-2-6c9aea63612f34757145f1fc45bdbd6431e222e9.zip
only inherit git as needed #190499
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/util-linux-2.13.ebuild5
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/util-linux/util-linux-2.13.ebuild b/sys-apps/util-linux/util-linux-2.13.ebuild
index d11bf07ff9f7..d0cf973480b1 100644
--- a/sys-apps/util-linux/util-linux-2.13.ebuild
+++ b/sys-apps/util-linux/util-linux-2.13.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.ebuild,v 1.1 2007/08/28 00:23:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.ebuild,v 1.2 2007/08/28 14:03:09 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils git
+inherit eutils
+[[ ${PV} == "9999" ]] && inherit git
MY_PV=${PV/_/-}
MY_P=${PN}-ng-${MY_PV}
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 7f5db766bc8a..18190ac0da34 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.4 2007/07/07 05:30:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.5 2007/08/28 14:03:09 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils git
+inherit eutils
+[[ ${PV} == "9999" ]] && inherit git
MY_PV=${PV/_/-}
MY_P=${PN}-ng-${MY_PV}