summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-08-09 09:36:30 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-08-09 09:36:30 +0000
commit6c03ab4d06f12c0297d5fdb59f9bc2a7c4a5bcbc (patch)
tree11bf5f979a1aeea2e8046eba241565afaba5a29c /sys-apps
parentStable for ppc64, wrt bug #518646 (diff)
downloadgentoo-2-6c03ab4d06f12c0297d5fdb59f9bc2a7c4a5bcbc.tar.gz
gentoo-2-6c03ab4d06f12c0297d5fdb59f9bc2a7c4a5bcbc.tar.bz2
gentoo-2-6c03ab4d06f12c0297d5fdb59f9bc2a7c4a5bcbc.zip
Version bump (bug #519456). Added rewritten init script
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/files/smartd-r1.rc29
-rw-r--r--sys-apps/smartmontools/smartmontools-6.3.ebuild65
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild6
4 files changed, 104 insertions, 4 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 632400c9aa45..097b470d9c3d 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.135 2014/01/07 09:15:04 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.136 2014/08/09 09:36:30 polynomial-c Exp $
+
+*smartmontools-6.3 (09 Aug 2014)
+
+ 09 Aug 2014; Lars Wendler <polynomial-c@gentoo.org>
+ +smartmontools-6.3.ebuild, smartmontools-9999.ebuild, +files/smartd-r1.rc:
+ Version bump (bug #519456). Added rewritten init script.
07 Jan 2014; Lars Wendler <polynomial-c@gentoo.org>
-smartmontools-5.38.ebuild, -smartmontools-5.39.1.ebuild,
diff --git a/sys-apps/smartmontools/files/smartd-r1.rc b/sys-apps/smartmontools/files/smartd-r1.rc
new file mode 100644
index 000000000000..d6273e6bffdc
--- /dev/null
+++ b/sys-apps/smartmontools/files/smartd-r1.rc
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd-r1.rc,v 1.1 2014/08/09 09:36:30 polynomial-c Exp $
+
+pidfile="/run/smartd.pid"
+command="/usr/sbin/smartd"
+command_args="-p ${pidfile} ${SMARTD_OPTS}"
+extra_started_commands="reload"
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+start_pre() {
+ if [ ! -f "/etc/smartd.conf" ] ; then
+ eerror "You should setup your /etc/smartd.conf file!"
+ eerror "See the smartd.conf(5) manpage."
+ return 1
+ fi
+ return 0
+}
+
+reload() {
+ ebegin "Reloading configuration"
+ start-stop-daemon --signal HUP --pidfile ${pidfile} ${command##*/}
+ eend $?
+}
diff --git a/sys-apps/smartmontools/smartmontools-6.3.ebuild b/sys-apps/smartmontools/smartmontools-6.3.ebuild
new file mode 100644
index 000000000000..c0eddc6b0216
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-6.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-6.3.ebuild,v 1.1 2014/08/09 09:36:30 polynomial-c Exp $
+
+EAPI="4"
+
+inherit flag-o-matic systemd
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps minimal selinux static"
+
+DEPEND="
+ caps? (
+ static? ( sys-libs/libcap-ng[static-libs] )
+ !static? ( sys-libs/libcap-ng )
+ )
+ selinux? (
+ sys-libs/libselinux
+ sec-policy/selinux-smartmon
+ )"
+RDEPEND="${DEPEND}
+ !minimal? ( virtual/mailx )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ # The build installs /etc/init.d/smartd, but we clobber it
+ # in our src_install, so no need to manually delete it.
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-initscriptdir="${EPREFIX}/etc/init.d" \
+ $(use_with caps libcap-ng) \
+ $(use_with selinux) \
+ $(systemd_with_unitdir)
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl
+ doman smartctl.8
+ else
+ default
+ newinitd "${FILESDIR}"/smartd-r1.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 2391ef4a8e8f..2e4ea97bcff1 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.15 2013/08/11 16:37:40 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.16 2014/08/09 09:36:30 polynomial-c Exp $
EAPI="4"
@@ -55,7 +55,7 @@ src_install() {
doman smartctl.8
else
default
- newinitd "${FILESDIR}"/smartd.rc smartd
+ newinitd "${FILESDIR}"/smartd-r1.rc smartd
newconfd "${FILESDIR}"/smartd.confd smartd
fi
}