summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-10 14:40:20 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-10 14:40:20 +0000
commit65d52db590138c31a3077acd7b0d6bb355193e6d (patch)
treec5ebc5c4d5cddb68f6185757e7f1d357a3e6c3c0 /sys-apps
parentStable on amd64 wrt bug #176297 (diff)
downloadgentoo-2-65d52db590138c31a3077acd7b0d6bb355193e6d.tar.gz
gentoo-2-65d52db590138c31a3077acd7b0d6bb355193e6d.tar.bz2
gentoo-2-65d52db590138c31a3077acd7b0d6bb355193e6d.zip
Version bump.
(Portage version: 2.1.3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.13_rc33
-rw-r--r--sys-apps/util-linux/util-linux-2.13_rc3.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index aa48dfcdcf5f..ed100052c3ed 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.197 2007/07/23 05:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.198 2007/08/10 14:40:19 vapier Exp $
+
+*util-linux-2.13_rc3 (10 Aug 2007)
+
+ 10 Aug 2007; Mike Frysinger <vapier@gentoo.org>
+ +util-linux-2.13_rc3.ebuild:
+ Version bump.
23 Jul 2007; Mike Frysinger <vapier@gentoo.org>
util-linux-2.12r-r7.ebuild:
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13_rc3 b/sys-apps/util-linux/files/digest-util-linux-2.13_rc3
new file mode 100644
index 000000000000..1c3e6fce7b5f
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.13_rc3
@@ -0,0 +1,3 @@
+MD5 b0c813ad57d04434ec7df96089f12716 util-linux-ng-2.13-rc3.tar.bz2 2638213
+RMD160 4aa2f8c833625d3226cea54ee485a978a37e5331 util-linux-ng-2.13-rc3.tar.bz2 2638213
+SHA256 c23489aca731e1b083554b60a11c334e8916fbe6d4b9dc1ad81edad8e9d7db1b util-linux-ng-2.13-rc3.tar.bz2 2638213
diff --git a/sys-apps/util-linux/util-linux-2.13_rc3.ebuild b/sys-apps/util-linux/util-linux-2.13_rc3.ebuild
new file mode 100644
index 000000000000..697ce25c8688
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.13_rc3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13_rc3.ebuild,v 1.1 2007/08/10 14:40:19 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+inherit eutils git
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-ng-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls old-linux selinux"
+
+RDEPEND="!sys-process/schedutils
+ !sys-apps/setarch
+ >=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-fsprobe=blkid \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use_with selinux) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS NEWS README* TODO docs/*
+}