summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-14 17:21:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-14 17:21:59 +0000
commit620a898262ea8c8ad95be66d5b4db2f06a407c3b (patch)
treee1794740ab0d3b7513da18c9f1914b93f59ce6e6 /sys-apps
parentThe games.eclass has dropped GAMES_CHECK_LICENSE support (since portage now h... (diff)
downloadgentoo-2-620a898262ea8c8ad95be66d5b4db2f06a407c3b.tar.gz
gentoo-2-620a898262ea8c8ad95be66d5b4db2f06a407c3b.tar.bz2
gentoo-2-620a898262ea8c8ad95be66d5b4db2f06a407c3b.zip
Fix missing limits.h and stddef.h wrt #394633 by Alexandre Rostovtsev. This is Debian patch 04-missing-includes.diff.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/usbutils/ChangeLog7
-rw-r--r--sys-apps/usbutils/files/usbutils-005-missing-includes.patch22
-rw-r--r--sys-apps/usbutils/usbutils-005.ebuild6
3 files changed, 32 insertions, 3 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index 12340251509f..6db5c2f738b3 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.126 2011/12/13 18:23:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.127 2011/12/14 17:21:58 ssuominen Exp $
+
+ 14 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> usbutils-005.ebuild,
+ +files/usbutils-005-missing-includes.patch:
+ Fix missing limits.h and stddef.h wrt #394633 by Alexandre Rostovtsev. This
+ is Debian patch 04-missing-includes.diff.
13 Dec 2011; Jeroen Roovers <jer@gentoo.org> usbutils-004.ebuild:
Stable for HPPA (bug #394577).
diff --git a/sys-apps/usbutils/files/usbutils-005-missing-includes.patch b/sys-apps/usbutils/files/usbutils-005-missing-includes.patch
new file mode 100644
index 000000000000..5d6d762d17b0
--- /dev/null
+++ b/sys-apps/usbutils/files/usbutils-005-missing-includes.patch
@@ -0,0 +1,22 @@
+This is 04-missing-includes.diff from Debian to resolve http://bugs.gentoo.org/394633
+
+--- usbhid-dump/include/uhd/dev_list.h
++++ usbhid-dump/include/uhd/dev_list.h
+@@ -27,6 +27,7 @@
+ #ifndef __UHD_DEV_LIST_H__
+ #define __UHD_DEV_LIST_H__
+
++#include <stddef.h>
+ #include "uhd/dev.h"
+
+ #ifdef __cplusplus
+--- usbhid-dump/src/usbhid-dump.c
++++ usbhid-dump/src/usbhid-dump.c
+@@ -39,6 +39,7 @@
+ #include <getopt.h>
+ #include <stdio.h>
+ #include <libusb-1.0/libusb.h>
++#include <limits.h>
+
+ #include "config.h"
+
diff --git a/sys-apps/usbutils/usbutils-005.ebuild b/sys-apps/usbutils/usbutils-005.ebuild
index 91b489c2257e..523f89c7c88c 100644
--- a/sys-apps/usbutils/usbutils-005.ebuild
+++ b/sys-apps/usbutils/usbutils-005.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-005.ebuild,v 1.1 2011/12/13 17:38:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-005.ebuild,v 1.2 2011/12/14 17:21:59 ssuominen Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
-inherit autotools python
+inherit autotools eutils python
DESCRIPTION="USB enumeration utilities"
HOMEPAGE="http://linux-usb.sourceforge.net/"
@@ -31,6 +31,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-missing-includes.patch
+
eautoreconf
if use python; then