summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 23:17:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 23:17:16 +0000
commit6038b849b53d66d627fa2a92f25cfed3b2c08a16 (patch)
tree65942bec71ed3d7ccb85bccce7b819444cc858d2 /sys-apps
parentAdd patch from upstream to fix typo in error msg #96009. (diff)
downloadgentoo-2-6038b849b53d66d627fa2a92f25cfed3b2c08a16.tar.gz
gentoo-2-6038b849b53d66d627fa2a92f25cfed3b2c08a16.tar.bz2
gentoo-2-6038b849b53d66d627fa2a92f25cfed3b2c08a16.zip
Add a patch by Diego Pettenò to fix BSD support #92586.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/grep/ChangeLog6
-rw-r--r--sys-apps/grep/files/grep-2.5.1-libintl.patch99
-rw-r--r--sys-apps/grep/grep-2.5.1-r8.ebuild3
3 files changed, 106 insertions, 2 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 55d6efdc72e6..67091f35d28d 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.46 2005/06/12 22:23:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.47 2005/06/13 23:17:16 vapier Exp $
+
+ 13 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/grep-2.5.1-libintl.patch, grep-2.5.1-r8.ebuild:
+ Add a patch by Diego Pettenò to fix BSD support #92586.
*grep-2.5.1-r8 (12 Jun 2005)
diff --git a/sys-apps/grep/files/grep-2.5.1-libintl.patch b/sys-apps/grep/files/grep-2.5.1-libintl.patch
new file mode 100644
index 000000000000..0bf601cabc17
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.5.1-libintl.patch
@@ -0,0 +1,99 @@
+Add libintl detection for BSD systems.
+
+Patch by Diego Pettenò.
+http://bugs.gentoo.org/92586
+
+ #--- configure.in
+ #+++ configure.in
+ #@@ -72,6 +72,7 @@
+ # dnl I18N feature
+ # ALL_LINGUAS="cs de el eo es et fr gl hr id it ja ko nl no pl pt_BR ru sl sv"
+ # AM_GNU_GETTEXT
+ #+AC_CHECK_LIB(intl, libintl_gettext)
+ #
+ # dnl DOS file name convention
+ # dnl sets HAVE_DOS_FILE_NAMES
+
+--- configure
++++ configure
+@@ -7754,6 +8827,80 @@
+
+
+
++echo "$as_me:$LINENO: checking for libintl_gettext in -lintl" >&5
++echo $ECHO_N "checking for libintl_gettext in -lintl... $ECHO_C" >&6
++if test "${ac_cv_lib_intl_libintl_gettext+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lintl $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char libintl_gettext ();
++int
++main ()
++{
++libintl_gettext ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_intl_libintl_gettext=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_intl_libintl_gettext=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_intl_libintl_gettext" >&5
++echo "${ECHO_T}$ac_cv_lib_intl_libintl_gettext" >&6
++if test $ac_cv_lib_intl_libintl_gettext = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_LIBINTL 1
++_ACEOF
++
++ LIBS="-lintl $LIBS"
++
++fi
++
++
+
+ echo "$as_me:$LINENO: checking for dos file convention" >&5
+ echo $ECHO_N "checking for dos file convention... $ECHO_C" >&6
diff --git a/sys-apps/grep/grep-2.5.1-r8.ebuild b/sys-apps/grep/grep-2.5.1-r8.ebuild
index bde3182758cc..94f05e71f113 100644
--- a/sys-apps/grep/grep-2.5.1-r8.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r8.ebuild,v 1.1 2005/06/12 22:23:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r8.ebuild,v 1.2 2005/06/13 23:17:16 vapier Exp $
inherit flag-o-matic eutils
@@ -35,6 +35,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-restrict_arr.patch
epatch "${FILESDIR}"/${PV}-utf8-case.patch
epatch "${FILESDIR}"/${P}-perl-segv.patch #95495
+ epatch "${FILESDIR}"/${P}-libintl.patch #92586
# uclibc does not suffer from this glibc bug.
use elibc_uclibc || epatch "${FILESDIR}"/${PV}-tests.patch