summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-11-01 00:56:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-11-01 00:56:08 +0000
commit5b2f58a7facddce010482f14bb06c90fb722e2b7 (patch)
treee562ca190f92671caeb7d8bc1acb1ca557b0b556 /sys-apps
parentUpdate EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking strict... (diff)
downloadgentoo-2-5b2f58a7facddce010482f14bb06c90fb722e2b7.tar.gz
gentoo-2-5b2f58a7facddce010482f14bb06c90fb722e2b7.tar.bz2
gentoo-2-5b2f58a7facddce010482f14bb06c90fb722e2b7.zip
Version bump. Thanks to Nathan Phillip Brink (ohnobinki)<ohnobinki@ohnopublishing.net>. Bug #341229
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pacman/ChangeLog8
-rw-r--r--sys-apps/pacman/pacman-3.4.1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-apps/pacman/ChangeLog b/sys-apps/pacman/ChangeLog
index 4471ea1d3bf7..241dae87c9ab 100644
--- a/sys-apps/pacman/ChangeLog
+++ b/sys-apps/pacman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pacman
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.1 2010/05/12 21:04:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.2 2010/11/01 00:56:08 hwoarang Exp $
+
+*pacman-3.4.1 (01 Nov 2010)
+
+ 01 Nov 2010; Markos Chandras <hwoarang@gentoo.org> +pacman-3.4.1.ebuild:
+ Version bump. Thanks to Nathan Phillip Brink
+ (ohnobinki)<ohnobinki@ohnopublishing.net>. Bug #341229
*pacman-3.3.3 (12 May 2010)
diff --git a/sys-apps/pacman/pacman-3.4.1.ebuild b/sys-apps/pacman/pacman-3.4.1.ebuild
new file mode 100644
index 000000000000..ee3e1e9cf6af
--- /dev/null
+++ b/sys-apps/pacman/pacman-3.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/pacman-3.4.1.ebuild,v 1.1 2010/11/01 00:56:08 hwoarang Exp $
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="Archlinux's binary package manager"
+HOMEPAGE="http://archlinux.org/pacman/"
+SRC_URI="ftp://ftp.archlinux.org/other/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc test"
+
+COMMON_DEPEND="app-arch/libarchive
+ virtual/libiconv
+ virtual/libintl
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-lang/python )"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/-Werror/d' configure.ac || die "-Werror"
+ # acinclude.m4 overrides libtool macros from /usr/share/aclocal, causing
+ # elibtoolize's ltmain.sh to incompatible with ./configure after
+ # eautoreconf is run.
+ sed -i -e '4,/dnl Add some custom macros for pacman and libalpm/d' acinclude.m4 || die "libtool fix"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --disable-git-version \
+ --disable-internal-download \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodir /etc/pacman.d || die
+}
+
+pkg_postinst() {
+ einfo "Please see http://ohnopub.net/~ohnobinki/gentoo/arch/ for information"
+ einfo "about setting up an archlinux chroot."
+}