summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-31 11:56:19 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-31 11:56:19 +0000
commit57fdfebdc70eb38a42b579919fe4fec137855760 (patch)
tree3962102202776d8948d2ff4f5c705f16b471aefd /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-57fdfebdc70eb38a42b579919fe4fec137855760.tar.gz
gentoo-2-57fdfebdc70eb38a42b579919fe4fec137855760.tar.bz2
gentoo-2-57fdfebdc70eb38a42b579919fe4fec137855760.zip
Backport a fix or two so we can stabilize this version.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog10
-rw-r--r--sys-apps/sandbox/files/0001-libsandbox-handle-more-at-functions.patch42
-rw-r--r--sys-apps/sandbox/files/sandbox-1.6-disable-qa-static.patch13
-rw-r--r--sys-apps/sandbox/sandbox-1.6-r1.ebuild98
4 files changed, 162 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index b09b6f6d74ea..69fb1e50a8ce 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.110 2009/03/31 11:44:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.111 2009/03/31 11:56:19 vapier Exp $
+
+*sandbox-1.6-r1 (31 Mar 2009)
+
+ 31 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/sandbox-1.6-disable-qa-static.patch,
+ +files/0001-libsandbox-handle-more-at-functions.patch,
+ +sandbox-1.6-r1.ebuild:
+ Backport a fix or two so we can stabilize this version.
*sandbox-1.7 (31 Mar 2009)
diff --git a/sys-apps/sandbox/files/0001-libsandbox-handle-more-at-functions.patch b/sys-apps/sandbox/files/0001-libsandbox-handle-more-at-functions.patch
new file mode 100644
index 000000000000..09462b7e1b64
--- /dev/null
+++ b/sys-apps/sandbox/files/0001-libsandbox-handle-more-at-functions.patch
@@ -0,0 +1,42 @@
+From 25425878243c5ca1ff21e6f479e585c60b943930 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 30 Mar 2009 19:56:29 -0400
+Subject: [PATCH] libsandbox: handle more *at functions
+
+Add some more *at functions to the main checking code.
+
+URL: http://bugs.gentoo.org/264320
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Reported-by: Harald van Dijk <truedfx@gentoo.org>
+---
+ libsandbox/libsandbox.c | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/libsandbox/libsandbox.c b/libsandbox/libsandbox.c
+index 88248af..c3f0b55 100644
+--- a/libsandbox/libsandbox.c
++++ b/libsandbox/libsandbox.c
+@@ -681,15 +681,20 @@ static int check_access(sbcontext_t *sbcontext, int sb_nr, const char *func,
+ sb_nr == SB_NR_CREAT ||
+ sb_nr == SB_NR_CREAT64 ||
+ sb_nr == SB_NR_MKDIR ||
++ sb_nr == SB_NR_MKDIRAT ||
+ sb_nr == SB_NR_MKNOD ||
+ sb_nr == SB_NR_MKNODAT ||
+ sb_nr == SB_NR__XMKNOD ||
+ sb_nr == SB_NR___XMKNOD ||
+ sb_nr == SB_NR___XMKNODAT ||
+ sb_nr == SB_NR_MKFIFO ||
++ sb_nr == SB_NR_MKFIFOAT ||
+ sb_nr == SB_NR_LINK ||
++ sb_nr == SB_NR_LINKAT ||
+ sb_nr == SB_NR_SYMLINK ||
++ sb_nr == SB_NR_SYMLINKAT ||
+ sb_nr == SB_NR_RENAME ||
++ sb_nr == SB_NR_RENAMEAT ||
+ sb_nr == SB_NR_LUTIMES ||
+ sb_nr == SB_NR_UTIMENSAT ||
+ sb_nr == SB_NR_UTIME ||
+--
+1.6.2
+
diff --git a/sys-apps/sandbox/files/sandbox-1.6-disable-qa-static.patch b/sys-apps/sandbox/files/sandbox-1.6-disable-qa-static.patch
new file mode 100644
index 000000000000..754ef01968c9
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.6-disable-qa-static.patch
@@ -0,0 +1,13 @@
+sandbox-1.7 traces static apps so disable the qa notice as it just scares
+users ... dont want scary stuff in stable!
+
+--- libsandbox/wrapper-funcs/__wrapper_exec.c
++++ libsandbox/wrapper-funcs/__wrapper_exec.c
+@@ -221,7 +221,6 @@
+ if (!FUNCTION_SANDBOX_SAFE(path))
+ return result;
+
+- sb_check_exec(path, argv);
+ }
+ #endif
+
diff --git a/sys-apps/sandbox/sandbox-1.6-r1.ebuild b/sys-apps/sandbox/sandbox-1.6-r1.ebuild
new file mode 100644
index 000000000000..14b3e665dda3
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.6-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r1.ebuild,v 1.1 2009/03/31 11:56:19 vapier Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/lzma-utils"
+RDEPEND=""
+
+EMULTILIB_PKG="true"
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-disable-qa-static.patch
+ epatch "${FILESDIR}"/0001-libsandbox-handle-more-at-functions.patch
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ mkdir "${WORKDIR}/build-${ABI}"
+ cd "${WORKDIR}/build-${ABI}"
+
+ multilib_toolchain_setup ${ABI}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf ${myconf} || die
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || die
+ done
+ ABI=${OABI}
+}
+
+src_test() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Checking sandbox for ABI=${ABI}..."
+ emake check || die "make check failed for ${ABI}"
+ done
+ ABI=${OABI}
+}
+
+src_install() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ emake DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage "${D}"/var/log/sandbox
+ chmod 0770 "${D}"/var/log/sandbox
+
+ local old=$(find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
+ if [[ -n ${old} ]] ; then
+ elog "Removing old sandbox libraries for you:"
+ elog ${old//${ROOT}}
+ find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -exec rm -fv {} \;
+ fi
+}