summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-15 05:33:52 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-15 05:33:52 +0000
commit525f79e86cc018bd8755ab32c21ea2a05748bd51 (patch)
tree024a513a189b5eb36e276c6794d60c351232aec2 /sys-apps
parentMark ppc64 stable #314035. (diff)
downloadgentoo-2-525f79e86cc018bd8755ab32c21ea2a05748bd51.tar.gz
gentoo-2-525f79e86cc018bd8755ab32c21ea2a05748bd51.tar.bz2
gentoo-2-525f79e86cc018bd8755ab32c21ea2a05748bd51.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/findutils-4.5.9.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index f1def9010935..ec3e0160ddac 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.193 2010/08/15 05:33:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.194 2010/08/15 05:33:52 vapier Exp $
+
+*findutils-4.5.9 (15 Aug 2010)
+
+ 15 Aug 2010; Mike Frysinger <vapier@gentoo.org> +findutils-4.5.9.ebuild:
+ Version bump.
15 Aug 2010; Mike Frysinger <vapier@gentoo.org> findutils-4.4.2.ebuild:
Mark ppc64 stable #314035.
diff --git a/sys-apps/findutils/findutils-4.5.9.ebuild b/sys-apps/findutils/findutils-4.5.9.ebuild
new file mode 100644
index 000000000000..c8d524d8c4f8
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.9.ebuild,v 1.1 2010/08/15 05:33:52 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+# mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}