summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-23 00:43:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-23 00:43:30 +0000
commit4e8b30de0783862bb755abf5a1a489fc93eb8ffe (patch)
tree9f79a42f19499bcb310e97c88ff15f528436d238 /sys-apps
parentAdd ~sparc to KEYWORDS (diff)
downloadgentoo-2-4e8b30de0783862bb755abf5a1a489fc93eb8ffe.tar.gz
gentoo-2-4e8b30de0783862bb755abf5a1a489fc93eb8ffe.tar.bz2
gentoo-2-4e8b30de0783862bb755abf5a1a489fc93eb8ffe.zip
Version bump.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-6.4.ebuild149
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-6.46
3 files changed, 161 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 44a9850769b0..6ead57689420 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.179 2006/09/30 20:54:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.180 2006/10/23 00:43:30 vapier Exp $
+
+*coreutils-6.4 (23 Oct 2006)
+
+ 23 Oct 2006; Mike Frysinger <vapier@gentoo.org> +coreutils-6.4.ebuild:
+ Version bump.
*coreutils-6.3 (30 Sep 2006)
diff --git a/sys-apps/coreutils/coreutils-6.4.ebuild b/sys-apps/coreutils/coreutils-6.4.ebuild
new file mode 100644
index 000000000000..6b683157da77
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-6.4.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.4.ebuild,v 1.1 2006/10/23 00:43:30 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+PATCH_VER="1.0"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~kingtaco/mirror/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( >=sys-devel/gettext-0.15 )
+ !net-mail/base64
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ =sys-devel/automake-1.9*
+ >=sys-devel/autoconf-2.59d
+ >=sys-devel/m4-1.4-r1
+ sys-apps/help2man"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ # fixup expr for #123342
+ if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
+ if [[ -x /bin/busybox ]] ; then
+ ln -sf /bin/busybox /bin/expr
+ else
+ eerror "Your expr binary appears to be broken, please fix it."
+ eerror "For more info, see http://bugs.gentoo.org/123342"
+ die "your expr is broke"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ PATCHDIR="${WORKDIR}/patch"
+ rm -f "${PATCHDIR}"/generic/001_*progress*
+
+ # Apply the ACL/SELINUX patches.
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
+ elif use acl ; then
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ chmod a+rx tests/sort/sort-mb-tests
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+ # There's no reason for this crap to use the private version
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --bindir=/usr/libexec/gnu"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] \
+ && myconf="${myconf} --without-included-regex"
+
+ use static && append-ldflags -static
+ econf \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+ emake || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/usr/lib/charset.alias
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ else
+ # For now, drop the man pages, collides with the ones of the system.
+ rm -rf "${D}"/usr/share/man
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-6.4 b/sys-apps/coreutils/files/digest-coreutils-6.4
new file mode 100644
index 000000000000..44f1c8a41a57
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-6.4
@@ -0,0 +1,6 @@
+MD5 2b7ce2e4a4134cc86c09b249e84311d5 coreutils-6.4-patches-1.0.tar.bz2 47993
+RMD160 122882cf72088c7abaff96bff9220efddfc6b1d7 coreutils-6.4-patches-1.0.tar.bz2 47993
+SHA256 daf083f0d37a8988aadb6e2fe030481add139f1cb2f9cfc60b9b62241ff459bc coreutils-6.4-patches-1.0.tar.bz2 47993
+MD5 a3806c709c7f063b80612be846a9d88c coreutils-6.4.tar.bz2 5294210
+RMD160 5e3628115ea814cddcfc6630a77c9079bd8676e0 coreutils-6.4.tar.bz2 5294210
+SHA256 75a6b82bb7e3d07bec5b9bd0fcdfdfdfb88f32728e5089972001b50e4148b87b coreutils-6.4.tar.bz2 5294210