summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-11-17 13:21:01 +0000
committerPacho Ramos <pacho@gentoo.org>2012-11-17 13:21:01 +0000
commit4e64e66e0928a2b39fc5e62c5293625054d10400 (patch)
tree11d331fa603da3c56fd97982abe93107f4b01a94 /sys-apps
parentVersion bump for security, bug #417269 (diff)
downloadgentoo-2-4e64e66e0928a2b39fc5e62c5293625054d10400.tar.gz
gentoo-2-4e64e66e0928a2b39fc5e62c5293625054d10400.tar.bz2
gentoo-2-4e64e66e0928a2b39fc5e62c5293625054d10400.zip
Show elog messages only when needed (#440526 by poletti.marco), disable silent rules.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog6
-rw-r--r--sys-apps/dbus/dbus-1.6.8-r1.ebuild23
2 files changed, 20 insertions, 9 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 184ba1c23dbd..e8515f612bb5 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dbus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.362 2012/10/14 14:38:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.363 2012/11/17 13:21:01 pacho Exp $
+
+ 17 Nov 2012; Pacho Ramos <pacho@gentoo.org> dbus-1.6.8-r1.ebuild:
+ Show elog messages only when needed (#440526 by poletti.marco), disable silent
+ rules.
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> dbus-1.6.8.ebuild:
ia64/s390/sh/sparc stable wrt #416725
diff --git a/sys-apps/dbus/dbus-1.6.8-r1.ebuild b/sys-apps/dbus/dbus-1.6.8-r1.ebuild
index 38a326f29d79..1d9fba7f5039 100644
--- a/sys-apps/dbus/dbus-1.6.8-r1.ebuild
+++ b/sys-apps/dbus/dbus-1.6.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.8-r1.ebuild,v 1.1 2012/10/04 08:26:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.8-r1.ebuild,v 1.2 2012/11/17 13:21:01 pacho Exp $
EAPI=4
inherit autotools eutils linux-info flag-o-matic python systemd virtualx user
@@ -79,6 +79,7 @@ src_configure() {
# libaudit is *only* used in DBus wrt SELinux support, so disable it, if
# not on an SELinux profile.
myconf=(
+ --disable-silent-rules
--localstatedir="${EPREFIX}/var"
--docdir="${EPREFIX}/usr/share/doc/${PF}"
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
@@ -169,16 +170,22 @@ src_install() {
}
pkg_postinst() {
- elog "To start the D-Bus system-wide messagebus by default"
- elog "you should add it to the default runlevel :"
- elog "\`rc-update add dbus default\`"
- elog
+ if [ "$(rc-config list default | grep dbus)" = "" ] ; then
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ fi
+
elog "Some applications require a session bus in addition to the system"
elog "bus. Please see \`man dbus-launch\` for more information."
elog
- ewarn "You must restart D-Bus \`/etc/init.d/dbus restart\` to run"
- ewarn "the new version of the daemon."
- ewarn "Don't do this while X is running because it will restart your X as well."
+
+ if [ "$(rc-status | grep dbus | grep started)" ] ; then
+ ewarn "You must restart D-Bus \`/etc/init.d/dbus restart\` to run"
+ ewarn "the new version of the daemon."
+ ewarn "Don't do this while X is running because it will restart your X as well."
+ fi
# Ensure unique id is generated and put it in /etc wrt #370451 but symlink
# for DBUS_MACHINE_UUID_FILE (see tools/dbus-launch.c) and reverse